PDA

View Full Version : [FIXED] sencha app upgrade -ext - problems accesing old version of ext?



seade
22 Apr 2014, 5:35 PM
I'm having no luck with upgrade -ext. Initially I was getting:



$ sencha app upgrade -ext
Sencha Cmd v5.0.0.116
[ERR] Cannot satisfy requirements for "ext"!
[INF] The following versions are available:
[INF] The following versions can be satisfied:
[ERR] The following versions cannot be satisfied:
[ERR] framework package dependency: ext@4.2.2.1144 (No matches!)
[ERR] Cannot resolve package requirements
at com.sencha.tools.pkg.PackageResolver.getPackages(PackageResolver.java:168)
at com.sencha.command.environment.FrameworkEnvironment.loadFrameworkPackage(FrameworkEnvironment.java:179

Specifying a path to ext was failing also. I came across a post that showed how to load the package manually (http://www.sencha.com/forum/showthread.php?283900-Sencha-Cmd-v5.0.0.116-not-able-to-generate-app-behind-proxy&p=1038974&viewfull=1#post1038974) and now I get:



$ sencha app upgrade -ext
Sencha Cmd v5.0.0.116
[ERR] Cannot satisfy requirements for "ext"!
[INF] The following versions are available:
[INF] 5.0.0.736 ( ... compatible back to 4.0)
[INF] The following versions can be satisfied:
[ERR] The following versions cannot be satisfied:
[ERR] framework package dependency: ext@4.2.2.1144 (No matches!)
[ERR] Cannot resolve package requirements
at com.sencha.tools.pkg.PackageResolver.getPackages(PackageResolver.java:168)
at com.sencha.command.environment.FrameworkEnvironment.loadFrameworkPackage(FrameworkEnvironment.java:179)
at com.sencha.command.environment.AppOrPackageEnvironment.loadFrameworkConfig(AppOrPackageEnvironment.java:56)


I am using OS X (10.9.2) and I have no proxy settings configured for Java (7 Update 55).

Am I missing a step somewhere? In both cases above the problem is an inability to access the version of ext I am attemptng to upgrade from - why does the upgrade to 5.0.0.736 need access to 4.2.2.1144?

Any advice on how to proceed?

Thanks,

Scott

Dumbledore
24 Apr 2014, 4:27 AM
i try this an my application and i run into the same error...

Need also help...


Bye, Dumbledore

seade
29 Apr 2014, 12:11 AM
It would be great to get some feedback on this. Is this likely to be something you will look at or should we be going down the less desirable path of generating a new app and attempting to somehow merge resources? If the latter are there any resources available to assist with this?

dongryphon
1 May 2014, 1:15 AM
Is your "ext.dir" property pointing at that version of Ext JS? You can see by running "sencha diag show".

dongryphon
1 May 2014, 1:17 AM
Thanks for the report! I have opened a bug in our bug tracker. I will see if we can ignore the missing old framework.

seade
1 May 2014, 3:36 PM
Is your "ext.dir" property pointing at that version of Ext JS? You can see by running "sencha diag show".

Running "sencha diag show" just gives the same error.


$ sencha diag show
Sencha Cmd v5.0.0.116
[ERR] Cannot satisfy requirements for "ext"!
[INF] The following versions are available:
[INF] 5.0.0.732 ( ... compatible back to 4.0)
[INF] 5.0.0.736 ( ... compatible back to 4.0)
[INF] The following versions can be satisfied:
[ERR] The following versions cannot be satisfied:
[ERR] framework package dependency: ext@4.2.2.1144 (No matches!)
[ERR] Cannot resolve package requirements
at com.sencha.tools.pkg.PackageResolver.getPackages(PackageResolver.java:168)
...

I see your follow up comment, but I am posting this so you are aware that this does not help.

Is there a manual way to check the value of ext.dir?

Thanks,

Scott

seade
14 May 2014, 5:39 PM
It turned out that the ext folder that should have contained the relevant version of ExtJS was missing. Instead of going for 5.0 I upgraded my app to the most recent cmd 4.0 (4.0.4.84) whereupon I resolved the problem by adding a copy of the framework to my app under the ext directory. It was not clear why this was absent, but adding it allowed me to move forward a small step.

I have still been unable to upgrade to 5.0, but it looks like I have other issues to resolve before I proceed down that path.

The takeout point is that you should ensure your app builds correctly with the currently used version of cmd before upgrading to a new one and you should probably also upgrade to the latest 4.0 release before attempting to upgrade to 5.0.

In my case I have some other issues to attend to before re-attempting the 5.0 upgrade.