PDA

View Full Version : [CLOSED] Container - alternate class name



LesJ
25 Apr 2014, 11:03 AM
I'm curious why the alternateClassName is Ext.AbstractContainer.

Is this for compatibility with Ext JS 4.2.2?

Then it should be named Ext.container.AbstractContainer.

// Ext JS 5
Ext.define('Ext.container.Container', {
extend: 'Ext.Component',

xtype: 'container',

alternateClassName: [
'Ext.Container',
'Ext.AbstractContainer' // <--- Why this class name?
],
.....

mitchellsimoens
29 Apr 2014, 4:09 AM
Thanks for the report! I have opened a bug in our bug tracker.