PDA

View Full Version : Cmd app build failed at second run



greatranil
26 Apr 2014, 9:04 AM
I followed the ExtJs 5 getting started guide and all went well.

But when i run "sencha app build" command for the second time i got the following error.

[ERR] Failed to parse CSS 3.0 style sheet: Encountered " "+" "+ "" at line 1, column 10012.
Was expecting one of:
<S> ...
")" ...
<S> ...


[ERR]
[ERR] BUILD FAILED
[ERR] com.sencha.exceptions.ExParse: could not parse css input content
[ERR]
[ERR] Total time: 6 seconds
[ERR] The following error occurred while executing this line:
<path\to\app>\.sencha\app\build
-impl.xml:274: The following error occurred while executing this line:

If I delete the build\production\POS\resources\<app-name>-all.css file then the build command works correctly.

bclinton
26 Apr 2014, 5:32 PM
I am having the same issue. The issue occurs when I run sencha ant ass. As greatranil mentioned, deleting the AppName-all.css from build/production/AppName/resources/ corrects the issue.

I'm not sure if it's related or not, but I am running sencha ant ass because I get the following error when building with sencha app build:


[ERR]

Did not find a system installed ruby runtime
Please install ruby for this platform and ensure that
a ruby command compatible with 1.8 or 1.9 is available
on the system path.
[ERR]
[ERR] BUILD FAILED
[ERR] com.sencha.exceptions.ExNotFound: Failed to detect ruby

I have tried ruby 1.9 and 2.0. I am currently using ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-linux]

I am using:
Sencha Cmd v5.0.0.116
ExtJS v5.0.0.736

dongryphon
26 Apr 2014, 11:22 PM
The 2nd build issue with Sass is fixed and will be available on the next refresh. In the meantime cleaning the css file is the way to workaround the issue.

bobringer
29 Apr 2014, 8:57 PM
I've just been running the following from the command line


sencha ant clean; sencha app build

Problem solved.