PDA

View Full Version : Which versions of ruby should be used with CMD 5.0.0.116?



bclinton
28 Apr 2014, 10:08 AM
When I try a sencha app build, I get the following error:


Did not find a system installed ruby runtime
Please install ruby for this platform and ensure that
a ruby command compatible with 1.8 or 1.9 is available
on the system path.

In the Introduction to Sencha Cmd section of the guide it says to install ruby on Ubuntu by using sudo apt-get install ruby2.0.0

I am using Debian 7.4 and I have tried both 1.9 and 2.0 versions of ruby and I get the same error. I am able to run sencha ant sass but not sencha app build. With either version installed i can run a ruby -v or which ruby and see that ruby is in my path.

I do not think the ruby version is the root of my issue, but I'd like to know which version I should be using so I am not trying to debug the issue with an incorrect ruby version.

mitchellsimoens
30 Apr 2014, 3:41 AM
I used ruby 2 but I'm not on a debian machine.

bclinton
1 May 2014, 11:20 AM
Thanks for the reply. I did try 2.0 but I had to make it from source. Perhaps I'll have better luck if try RVM.

christocracy
5 May 2014, 2:39 PM
Thanks for the reply. I did try 2.0 but I had to make it from source. Perhaps I'll have better luck if try RVM.


yes, use RVM.