PDA

View Full Version : [OPEN] Error upgrading from ExtJS 4.2.1 to ExtJS 5



xjscrafter
2 Jun 2014, 8:47 AM
I executed the following as specified in the ExtJS 5 upgrade guide:

sencha app upgrade -ext

And I got this output with error:

sencha app upgrade -ext
Sencha Cmd v5.0.0.160
[INF] Downloading ext package...
[INF] Source File : http://cdn.sencha.com/cmd/packages/ext/5.0.0.970/ext.pkg
[INF] Downloading : ....................
[INF] Extracting ext package...
[INF] Package is already local: ext/5.0.0.970
[INF] Extracting : ....................
[INF] Loading configuration for framework directory: C:\Sencha\Cmd\repo\extract\ext\5.0.0.970
[INF] Removing existing framework at C:\atlantis\amc\gui\src\main\ext
[INF] upgrading application
[INF] Upgrading to sdk at C:\atlantis\amc\gui\src\main\ext
[INF] Updating application and workspace from Ext JS 4.2.1.883 / Cmd 4.0.2.67
[WRN] Use merge tool to resolve conflict: C:\atlantis\amc\gui\src\main\usx\.sencha\app\sencha.cfg
[ERR]
[ERR] BUILD FAILED
[ERR] com.sencha.exceptions.ExProcess: Failed creating background process
[ERR]
[ERR] Total time: 1 second
[ERR] org.mozilla.javascript.WrappedException: Wrapped com.sencha.exceptions.BasicException: com.sencha.exceptions.ExProcess: Failed creating background process
(C:\Sencha\Cmd\5.0.0.160\ant\ant-util.js#849)
[ERR]
The application was last modified by an older version of Sencha Cmd (4.0.2.67)
the current is 5.0.0.160.
Please run "sencha app upgrade" to update to 5.0.0.160.

xjscrafter
2 Jun 2014, 8:51 AM
And when I execute "sencha app upgrade" I get this:

Sencha Cmd v5.0.0.160
[INF] upgrading application
[INF] Upgrading to sdk at C:\atlantis\amc\gui\src\main\ext
[INF] Updating application and workspace from Ext JS 4.2.1.883 / Cmd 3.0.0.250
[ERR] org.mozilla.javascript.WrappedException: Wrapped java.lang.NullPointerException (anonymous#336)
[ERR]
The application was last modified by an older version of Sencha Cmd (0.0.0.0)
the current is 5.0.0.160.
Please run "sencha app upgrade" to update to 5.0.0.160.

jsakalos
2 Jun 2014, 1:25 PM
See this answer: http://stackoverflow.com/a/23999896/692525

dongryphon
3 Jun 2014, 8:58 PM
Thanks for the report! I have opened a bug in our bug tracker.