PDA

View Full Version : [FIXED] Loading Tree classes on demand doesn't work



mankz
3 Jun 2014, 10:37 PM
Ext.define('Ext.view.NodeCache', {
statics: {
importElementMethods: Ext.dom.CompositeElementLite.importElementMethods,
range: document.createRange && document.createRange()
},


Hard crash here since 'Ext.dom.CompositeElementLite' is not yet defined/loaded.

mitchellsimoens
5 Jun 2014, 4:07 AM
Thanks for the report! I have opened a bug in our bug tracker.

LesJ
5 Jun 2014, 5:33 AM
Ext.define('Ext.view.NodeCache', {
statics: {
importElementMethods: Ext.dom.CompositeElementLite.importElementMethods,
range: document.createRange && document.createRange()
},


Hard crash here since 'Ext.dom.CompositeElementLite' is not yet defined/loaded.

mankz, can you explain better how this problems exhibits itself when loading Trees on demand?

I have a 4.2.2 application that uses a few trees which are loaded on demand, so I'm curious what to look for when I start upgrading to 5.0.

Thx

mankz
5 Jun 2014, 2:23 PM
What I mean by load-on-demand is just loading the Class on demand. Not the store or nodes etc.