PDA

View Full Version : [FIXED] Ext.layout.container.Box should require Ext.resizer.Splitter



mankz
5 Jun 2014, 4:32 PM
Since it uses it. Giving a sync loading warning right now.


insertSplitter: function (item, index, hidden, splitterCfg) {
var splitter = {
xtype: 'splitter',
id: item.id + '-splitter',
hidden: hidden,
splitterFor: item,
synthetic: true // not user-defined
},
at = index + ((splitterCfg.collapseTarget === 'prev') ? 1 : 0);

splitter[this.names.height] = '100%';
if (splitterCfg) {
Ext.apply(splitter, splitterCfg);
}
item.splitter = this.owner.add(at, splitter);
},

mitchellsimoens
6 Jun 2014, 4:40 AM
Thanks for the report! I have opened a bug in our bug tracker.