PDA

View Full Version : Datefield Bug, Months and Years, Firefox 29.0.1



chrishatton
6 Jun 2014, 12:22 PM
When using Firefox 29.0.1, ExtJS 4.2, months and years don't get rendered properly making it unusable. Works in Chrome and IE.

Does anyone have a workaround/bug fix?

Gary Schlosberg
6 Jun 2014, 2:54 PM
I'm not able to reproduce this. Do you have a test case which exhibits the behavior?
https://fiddle.sencha.com/#home

chrishatton
7 Jun 2014, 12:39 AM
Most annoyingly, I can't reproduce it in Fiddle either. I tried it with Firefox 29.0.1 on Windows 7 and it works fine. The problem seems to be with Firefox 29.0.1 on Windows 8.1

The problem presents itself not only in my own project but also in the Ext JS Kitchen Sink, Forms > Register Form example on your website.

Screenshot from the Kitchen Sink:
49265

I think you can see the problem. The months and years are not rendered within the viewable area.

Phil Guerrant
10 Jun 2014, 8:03 AM
I can't repro this on ff 28 or 30 on win 8.1 (wasn't able to try 29).

Just curious what are your browser zoom settings? If not 100%, does changing to 100% correct the issue

chrishatton
10 Jun 2014, 11:46 PM
Well done, I think you have found the problem. It never occured to me to check my zoom settings. At least I now how to deal with helpdesk calls of this nature now. Haven't tried on the Win8/FF29.0.1 setup yet, but I'm sure it is just the same problem. Will try later on today and let you know.

chrishatton
11 Jun 2014, 12:47 PM
Yeah, tried with Win8/FF combo and that was the problem