PDA

View Full Version : .NET MVC website with EXT Js deployment on IIS



pessi_mca
12 Jun 2014, 6:48 AM
Hi Friends,

I am working on one PoC where i am using MVC website with Ext JS. Site is working good on developer system but having issue when configured on servers. We are getting blank page (ext js code files are not loading) when configured the website on servers. Could you please me if there are any steps to configure website with ext js on server.

My Config: Window 2012 server with IIS 4.5, Visual Studio 2012 and Ext JS 4.2

Thanks in Advance.


Rgds
Pessi

Gary Schlosberg
12 Jun 2014, 8:57 AM
The Getting Started guide is a good place to start:
http://docs.sencha.com/extjs/4.2.1/#!/guide/getting_started

There's a Web Server section with a link for installing on Windows.

pessi_mca
12 Jun 2014, 10:17 AM
Thanks Gary for quick response.

I could not find more help on given url for Windows 2012 server with IIS 8.5. My application is running but not loading ViewPort (ext js).

I copied ext sdk on c:\inetpub\wwwroot\ but no success. Might be i am missing some more configurations. Could you please help me to configure my site.

Thank you.

Rgds
Pessi

Gary Schlosberg
12 Jun 2014, 11:28 AM
Oh sorry, meant to include another link as well. Have you looked at your mime-types?
http://www.sencha.com/forum/showthread.php?246480

cmeans
20 Jun 2014, 8:07 AM
Are you deploying a built version (where all code is in one file)? or still relying on ExtJS to dynamically load classes individually?

If it's the former, then most likely you have a build error (a class is referenced that wasn't included in the build). If the latter, then check to make sure that there are no HTTP 400's (missing classes/dependencies etc.)

Use Firebug to help debug load/runtime startup issues (check the error console as well).

-Chris