PDA

View Full Version : Rendering issues in Firefox 30



slsmithtx
16 Jun 2014, 10:10 AM
Has anyone noticed a change in the behavior of objects in the latest version of Firefox -- 30? It seems like especially with windows, that the objects are now being rendered long before the window shows, and this is causing occasional issues with code that is being called in afterrender event handlers and other post rendering code. Objects that are supposed to exist, don't exist yet so the code can't access them. I can see it when I click a button to open a window with a grid in it. Before the window would appear and the ajax call to load the grid would happen at about the same time and you would see the load mask in the grid. Now I can see the ajax calls happening well before the window appears and when it appears the data is already there.

willigogs
17 Jun 2014, 5:07 AM
There is a known Firefox bug which Mozilla have fixed in version 31, but this currently isn't scheduled for release until mid-July.If this is the same issue I've experienced, then this only occurs when you have Firebug / the debugger open - therefore hopefully the majority of users shouldn't hit this condition. The only workaround I can think of is to detect users running Firefox 30, and offer some form of information popup, or hound Mozilla into releasing 31 early...

slsmithtx
17 Jun 2014, 7:10 AM
I'd heard there was a Firefox bug that effected Firebug 2. Hadn't realized it was causing this issue as well. But you're right. When I turn off Firebug the code is behaving normally. Thanks.