PDA

View Full Version : Brower compatiblity UI Issues



AJAIN32
21 Jul 2014, 1:26 AM
Hi,

I have some UI issues, I have used one image and i am giving the image width, height, margin in a seperate css and that image is coming as expected in IE 9 Document mode.When i run same code in IE7 Document mode, The image is getting cropped slightly or i would say it is appering small.
One more issue i am facing - i am using a button and it is disabled by a condition. so in disabled state the button border is not coming in IE 7 Mode, and its coming perfect in IE9.
can anyone please tell me that how we can handle these browser compatibilty issues?

Thanks,
Ankit

Gary Schlosberg
24 Jul 2014, 11:12 AM
Compatibility modes are not supported.

AJAIN32
25 Jul 2014, 3:57 AM
Please suggest, how can we take care of such things.

Sencha has cross brower compatibilty ?

Please let me know any useful information to handle these issues.

Thanks,
Ankit

burnnat
28 Jul 2014, 6:45 AM
You can force IE to use standards mode rather than compatibility mode by setting the X-UA-Compatible header for your page; see this post (http://www.sencha.com/forum/showthread.php?238735-IE-9-compatibility-view&p=876814&viewfull=1#post876814) for information. Also be sure you've set the correct doctype (http://www.sencha.com/forum/showthread.php?137309) on your page.

AJAIN32
29 Jul 2014, 12:23 AM
Thanks for the reply,

I have already given <meta http-equiv="X-UA-Compatible" content="IE=edge"> in the .html file that i am rendering. but still it takes the document mode as it is.
Ideally it should run in the latest document mode ?

Please suggest

Regards,
Ankit

burnnat
30 Jul 2014, 6:15 AM
Here is an MSDN article (http://msdn.microsoft.com/en-us/library/ff405803%28v=vs.85%29.aspx) that explains how IE chooses document modes. A couple additional things to check:


If you have the IE developer tools open, the settings there will override any doctype or meta tags in the HTML page.
If the website is loaded from the local intranet, you may have the "Display intranet sites in Compatibility View" option checked in the IE settings.

Beyond that, I recommend reading the linked article thoroughly, as the process used by IE to determine document mode is somewhat complex and not terribly intuitive.