PDA

View Full Version : Totals in columns works, whenever they want to



rune carlsen
12 Mar 2008, 1:59 AM
I have serveral views, both with and without totalcolumns. They usually work, but for some strange reason, in many views, they just dont. The bottom total line, is just missing. Though it works smoothly in the Notes-client, it seems to be a bug other places. I have tried to figure out why this is, changing settings, copying views that work, changing them etc, but no, can't figure this out.

So, is this a knows bug? - because, it sure is...

best regards,
Rune Carlsen

rune carlsen
12 Mar 2008, 6:07 AM
I (uh, a friend that is) tried this some more, and experienced the following:

IE alone: everything OK
Installed Firefox 2.x: Didn't work in FF2 or IE7
Uninstalled FF2: Working in IE again
Installed FF3beta4: Works in FF3 and IE7

So, there seems to be something very very very strange going on. The browsers and their version between eachother does seem to conflict and make the behavor of the totalcolumns very strange.

Having said that, I have also noticed the following:

The views that have columns that don't work, also seems to be missing the last document/record in the view. So, it seems to "eat" the last document, and drop the rest (being the document itself and the total calculation). Strange indeed.

When you combine all this, and also take into consideration that on my computer, running FF2 and IE7, SOME views work and SOME don't.....

Confused? Welcome !

rune carlsen
13 Mar 2008, 12:21 AM
Would be nice if someone could verify this....

jratcliff
13 Mar 2008, 8:40 AM
Would be nice if someone could verify this....

Sorry rune, Rich and I've been busy finishing up the next release and we missed your post yesterday. I'm adding some views to the OpenNTF demo with totals in columns to test things out.

You can see things here > http://openntf.org/extnd/demo.nsf

~Jack R.

rune carlsen
1 Apr 2008, 12:48 AM
Seriously, there are major problems with the mentioned topic, and also, when getting more records, it seems to stop listing them up. As now, my view suddenly only shows 3 pages, and on the past page, there are for sure missing documents.

They are showing up in the Notes client, but not on web :(

The problem seems to be with the count of documents.

If you look at this image:

http://www.rune.no/misc/img/extjs_1.jpg

The last document, which is on the bottom of page 3, is the document of "Dahl". Seems ok. But, if you look in the Notes client:

http://www.rune.no/misc/img/extjs_2.jpg

There should be one more document. Meaning, the web-ui should have added one more page with a new document.

So, what happens if I duplicate that document? Well, this is what happens in the Web UI:

http://www.rune.no/misc/img/extjs_3.jpg

You can now see that the document exist, duplicated, and it's on a new "page", this is now page 4.

And in the Notes client, everything ofcourse works as normal:

http://www.rune.no/misc/img/extjs_4.jpg

Is this a known bug or?

PS I am posting this in the same topic as the totals, because I think this has to do with the same thing.

rune carlsen
4 Apr 2008, 12:58 AM
Anyone?

jratcliff
4 Apr 2008, 5:13 AM
Anyone?

Did you get my PM a couple of days ago? I can't reproduce this so I wanted to work with you offline on it.

~Jack R.