PDA

View Full Version : Problem with action buttons if formula has a hyphen



JimStoner
12 Mar 2008, 12:16 PM
Hi,

I'm using Ext.nd beta 1 to display a view with an action bar. The action bar has one action to create a new document. The action has the following formula:

@Command([Compose]; 'user-request')

However, the action bar does not show up in the web browser when the second parameter of the @Command has a hypen. If I remove the hyphen, like changing it to @Command([Compose]; 'userrequest'), the action bar will display correctly.

Is this a known issue?

JimStoner
12 Mar 2008, 12:26 PM
Actually, I just found another related issue. The @Command cannot have a space in it, or the action bar won't display.

@Command([Compose];"userrequest") will display correctly.
@Command([Compose]; "userrequest") will not display at all.

This may already be known, but I thought I'd add it just in case.

jratcliff
12 Mar 2008, 12:58 PM
Thanks for reporting this! Rich did this portion of the code so I'll make sure he knows about this.

~Jack R.

RWaters
12 Mar 2008, 3:00 PM
I'll fix this for the next release. The regex that parses out that value does not account for non alpha characters.

Mike Amberg
13 Mar 2008, 7:48 AM
Rich,

I wonder if this was the problem I had with the "Shared Actions" not displaying which i reported previously in another thread. I will try to check and report back in this threqad

Mike Amberg
13 Mar 2008, 8:17 AM
Rich,

Nope ... not the problem with shared actions ... the regular action shows but the identical shared action doesn't

<actionbar bgcolor='#002060' bordercolor='red'>
<actionbuttonstyle bgcolor='#002060' displayborder='always'/>
<font size='9pt' color='white'/><border style='solid' width='0px 0px 2px' color='red'/>
<action title='AddNewOffice'>
<code event='click'>
<formula>@Command([Compose];"Directory")</formula>
</code>
</action>
<sharedactionref id='3'/>
</actionbar>