PDA

View Full Version : Layout Error: YAHOO.ext.BorderLayout is not a constructor



jay@moduscreate.com
24 Oct 2006, 11:15 AM
Folks,

i get an error in firebug:
YAHOO.ext.BorderLayout is not a constructor

I'm following the layout examples to a T.

One thing that has me confused:
when i go to dowload the YUI, i see 0.11 or something like that.
However, jack's using some libs (for the examples) off of yahoo page and they are 2.5/2.6/etc.

Thoughts?

Thanks.
-Jay

jay@moduscreate.com
24 Oct 2006, 2:55 PM
yeah the problem is the fact that i was using the available version of jack's YUI extensions and not his 33 version like he's doing in his examples. :)

i also got rid of that pesky grid (not needed).

Jack, again thanks so much for your hard work. You're paving the way for so many of us. you're a leader here w/ all of your examples & documentation.

jack.slocum
24 Oct 2006, 5:32 PM
Thanks dj. I appreciate the positive feedback. :)

BorderLayout isn't in the standard download as it's still being tested for the next release (.33). There will be a public beta download in the next day or so.

Don't pay attention to the YUI file versions. Those are Akamai file versions, not the yui lib versions.