PDA

View Full Version : Problem running the ExtJs application



bevara.siva
2 Dec 2014, 5:12 AM
Hi,


We have created our application using Sencha Architect 3.
We have made it compatible with Sencha Cmd 5, by running the "generate app" command from the sdk.


We have build the application using the following command from the application directory.
"sencha app build production"
It build the application properly and created the files in the "deploy/production" folder.
I have deployed this folder in the IIS and trying to run the application.


Its giving error in the app.js (Minified JS).
How can I debug the application to know the error.


Please suggest.


Regards,
SivaPrasad.B

Alok.Ranjan
3 Dec 2014, 3:21 AM
Try deploying test build and see if problem persists.

bevara.siva
3 Dec 2014, 5:13 AM
Thank you for the response.
I have build the application in test mode.
sencha app build test
But still not able to debug the application.
I am getting the following error in the app.js.
Uncaught TypeError: undefined is not a function

Please help.

Regards,
SivaPrasad.B

Alok.Ranjan
3 Dec 2014, 10:31 PM
I will recommend you to build a the initial application which gets created when you create a new project using Sencha Cmd. Build that project and deploy the same. This will help you to isolate your deployment concern with your code problem.

lumberjack
4 Dec 2014, 12:44 PM
I will recommend you to build a the initial application which gets created when you create a new project using Sencha Cmd. Build that project and deploy the same. This will help you to isolate your deployment concern with your code problem.

I agree. Try generating the application structure using Sencha CMD, do a build, and see if any errors are found. If this approach isn't an option, could you please provide a stack trace that produces the error you're receiving?

Thanks,

Brian