PDA

View Full Version : Missing Ext.chart.Mask in 5.1



amitmehra
9 Feb 2015, 5:00 AM
Ext.chart.Mask class is missing in 5.1 but was present in 4.2.2. Does anyone know its substitute class in 5.1 ?

Basically this class was used to trigger select event in charts and i want to port my application to 5.1 but unable to find similar functionality in 5.1

joel.watson
11 Feb 2015, 9:57 AM
Ext.chart.Mask class is missing in 5.1 but was present in 4.2.2. Does anyone know its substitute class in 5.1 ?

Basically this class was used to trigger select event in charts and i want to port my application to 5.1 but unable to find similar functionality in 5.1

Hi amitmehra--

Which charts package are you using?

Thanks
Joel

amitmehra
12 Feb 2015, 8:53 PM
I suppose, in 4.2.2 there is only one chart package but in 5.1 i was trying with sencha-charts.

joel.watson
13 Feb 2015, 6:13 AM
I suppose, in 4.2.2 there is only one chart package but in 5.1 i was trying with sencha-charts.

Thanks for the clarification. In the new sencha-charts package, the functionality to replicate selection via a mask does not currently exist. There is a feature request open for this, however (EXTJS-16117).

Thanks!
Joel