PDA

View Full Version : Install of Jetbrains plugin for Sencha ExtJS into WebStorm 10.0.1 fails on OSX



cassebn
9 Apr 2015, 10:22 AM
When trying to install the new ExtJS plugin into WebStorm 10.0.1 it hangs and WebStorm will not launch.

Note: If you remove the plugin from ..Library/Application Support/WebStorm10, then WebStorm will launch.

Cannot attach crash report as too long for forum attachments, so here is initial details:

Date/Time: 2015-04-09 10:24:20 -0700
OS Version: 10.9.5 (Build 13F1066)
Architecture: x86_64
Report Version: 18

Command: WebStorm
Path: /Applications/WebStorm.app/Contents/MacOS/webstorm
Version: 10.0.1 (WS-141.506)
Parent: launchd [811]

PID: 2805
Event: hang
Duration: 5.56s
Steps: 56 (100ms sampling interval)

Hardware model: MacBookPro11,3
Active cpus: 8
Fan speed: 2156 rpm

Free pages: 2511907 pages (-8484)
Pageins: 1 pages
Pageouts: 0 pages
Swapins: 0 pages
Swapouts: 0 pages


Process: webstorm [2805]
Path: /Applications/WebStorm.app/Contents/MacOS/webstorm
Architecture: x86_64
Parent: launchd [811]
UID: 501
Task size: 49182 pages (+77)
CPU Time: 0.087s

Mark.Brocato
9 Apr 2015, 11:12 AM
I noticed this once or twice over the last few weeks after installing a new version of the plugin. When it happened I would just kill the WebStorm process and try again. It always seemed to work the second time around and would never have a problem after that. I'm not sure if this is due to the Ext JS plugin specifically, or maybe just a bug in WebStorm 10 in general. It might be due to initial indexing of the app or just running with a new plugin for the first time. I will investigate further.

Mark.Brocato
9 Apr 2015, 6:51 PM
Found the problem. A new version should be up Friday, 4/10.

Mark.Brocato
10 Apr 2015, 4:18 AM
A new version, 0.1.211, is available which fixes this issue. You can download it by selecting "Check for Updates..." from the IDE menu.

cassebn
10 Apr 2015, 8:30 AM
Thanks for the quick work Mark! WebStorm, for me, is now running with your latest Sencha ExtJS (0.1.211) plugin.