PDA

View Full Version : JetBrains Setup



rabelanger
14 Apr 2015, 8:45 AM
Hi,

I couldn't find the documentation for installing this plugins. Does this work with the ExtJs libraries installed (ExtJs GPL-4.0 or higher) or it needs to be removed? What are the minimum requirement for it to work?

I installed it and the auto update requires were getting removed even if they were used, jsdoc comment kept saying class didn't exists and all extjs xtype couldn't be find. Any doc around or are these bugs?

Running WebStorm 10.0.1
Thanks, looking forward for this!

Rafael

Chris.OBrien
14 Apr 2015, 9:29 AM
We have an announcement at the top of the forum, but can be easily missed. We're working on putting in links to our guide in the next release of the plugin so it can be easier to find. Here's the JetBrains Plugin Guide (http://docs.sencha.com/extjs/6.0/tools/jetbrains_ide_plugin.html).

The requirements are listed on that page, but you should be good to go with Ext JS 4 and WebStorm 10.x

When you say the auto requires are being removed, you can disable that functionality as mentioned in the Required & Uses section of our guide (http://docs.sencha.com/extjs/6.0/tools/jetbrains_ide_plugin.html#Requires__amp__Uses). Goto:
Preferences->Other Settings->Sencha->Manage requires array and uncheck the second checkbox.

However, you say it is removing requires that are actually in use. Could you provide an example of what you might be seeing in more detail?

Mark.Brocato
14 Apr 2015, 9:32 AM
The first thing to do it make sure that the unminified Ext JS source code is in your project. If not, you can add it as a custom library. Note that just having the minified ext-all.js is not enough. The unminified source is required. Any version of Ext 4+ is fine.

rabelanger
14 Apr 2015, 9:59 AM
Ok the guide was straight forward, I removed the library and added the ext folder as a resource folder. This fixed my problems.Thanks,Rafael