PDA

View Full Version : [FIXED] Fresh universal project does not 'sencha app refresh'



robboerman
14 Apr 2015, 12:44 PM
I created a simple app and am trying to refresh the bootstrap using sencha app refresh. When I do it fails on the theme. When I add toolkit: 'classic' to the app.json it does work. But that kind of defeats the purpose of a universal app.
Even on a newly created project without any changes this does not work.



>sencha generate app FooBar /tmp/foobar
>cd /tmp/foobar
>sencha app refresh
Sencha Cmd v6.0.0.92
[WRN] Failed to resolve package theme-neptune
[ERR] Theme "theme-neptune" not found
[ERR] Required package "theme-neptune" not found


PS. I am trying to refresh to load in dependencies in an ExtJS package

Gary Schlosberg
14 Apr 2015, 1:47 PM
Thanks for the report. You'll need to add a line to your app.json:


"toolkit": "classic", // or modern

robboerman
15 Apr 2015, 12:57 AM
Hi Gary,

That's what I did, like I wrote in my report. It seems strange though that I have to specify the toolkit when I am building a universal app. How does that work with the theme for the modern and classic part of the app? The Modern does not use theme-neptune.

dongryphon
15 Apr 2015, 11:04 PM
Looks like you have the right version of Cmd (6.0.0.92)... odd. Can you post the full log from sencha app refresh?

robboerman
16 Apr 2015, 1:01 AM
Of course, I attached the output of generating the app and then refreshing it below

52182

dongryphon
17 Apr 2015, 9:09 PM
Thanks - found it. Moving to Bugs....

dongryphon
17 Apr 2015, 9:10 PM
Err... I mean, creating a ticket...

dongryphon
17 Apr 2015, 9:13 PM
As a work around, try removing theme from the top-level of app.json. It should not be there for a Universal App... It shouldn't cause this problem, however, so really two bugs. :p

GSandoval-Greentree
18 Apr 2015, 6:11 PM
Don,
I encountered this message when running `sencha app upgrade` on a 5.x app. Also using
Sencha Cmd v6.0.0.92