PDA

View Full Version : [FIXED] Modern Ext.Msg popups not hiding



robboerman
15 May 2015, 4:32 AM
When I open an alert or confirm (or any other sheet), I cannot hide it. On hide(), the backdrop hides, but not the popup itself.

It seems to be caused by the show and hide animations. When I disable those on Ext.MessageBox, the sheet does hide.


Ext.Msg.alert('foo','bar');

evant
15 May 2015, 5:17 AM
Thanks for the report! I have opened a bug in our bug tracker.

worthlutz
16 Jun 2016, 12:59 PM
How was this fixed? I'm using ExtJS 6.0.2.437 Modern.

I am having a problem where sheets and Ext.Msg will not hide. This occurs only after aborting an AJAX request on a store totally unrelated to the Message Box and the Sheets having the problem.

I just spent two days tracking down the statement causing the problem(the request abort) and finding out that it is also related to animation.

The quick and dirty fix is to remove animation on sheets and Ext.Msg.

in launch:


Ext.Msg.defaultAllowedConfig.showAnimation = false;
Ext.Msg.defaultAllowedConfig.showAnimation = false;


in overrides/Sheet:


config: {
hideAnimation: null,
showAnimation: null
}

for my components which extend Sheet.

My Questions:

How can aborting an Ajax request mess up the animation on these components?

Where can I start looking?

vikwin
10 May 2017, 3:21 AM
Hi!
I'm confronted with the same bug on ExtJS 6.2.1.167 Modern. It happens just every once in a while on a sheet that is supposed to be hidden by two ways: Either with animation when clicking on the mask, or without animation by calling mySheet.hide(false). It sometimes even happens when hide(false) is being called.
The sheet then just stays in position and cannot be hidden. Calling mySheet.getHidden() from console yields true. Calling mySheet.destroy() will destroy the panel but not the mask.

Is there any fix or workaround for this?

EDIT:
Might be of helping to track down the issue: I just saw that this seems to be related to the showAnimation not ending, the css transitioning attributes remain on the dom element.
Due to customer demands, I cannot disable the show animation in my application. So I'm still searching for a solution to this.
My browser info: Chromium Version 58.0.3029.81 Built on Ubuntu , running on LinuxMint 17.3 (64-bit)