PDA

View Full Version : WebStorm plugin early access build expires on 7 june 2015



eser
7 Jun 2015, 6:04 AM
Where can I obtain sencha plugin for WebStorm?
My plugin early acess build expires on 7 june 2015.
There is no new plugin at https://plugins.jetbrains.com/plugin/7740?pr=phpStorm.

svenna
8 Jun 2015, 10:19 PM
Looks like Sencha will start charging for the plugin. The plugin access it now listed in the new license packages, and not included in the "Pro" package, but not in the "Standard" package, so I guess it will also be exluded from any kind of free/gpl package.

ref Sencha e-mail July 2nd.

sebastian2015
9 Jun 2015, 1:04 AM
Is there any official statement ? I received no e-mail regarding the license change. I just recognized that my plugin does not work correctly. Can I already download the commercial release?

svenna
9 Jun 2015, 1:25 AM
If you navigate Products => Frameworks => ExtJS, you will find this link in the first paragraph.

http://www.sencha.com/products/extjs/newpkg/

As you can see the plugin is part of Pro and Premium and not Standard.

GPL, however, I really don't know, but at least it won't be free.
And also, I don't know anything about 0.3 being the latest preview version, or if there will be a 0.4 before 0.3 expires.

Chris.OBrien
10 Jun 2015, 5:22 AM
Where can I obtain sencha plugin for WebStorm?
My plugin early acess build expires on 7 june 2015.
There is no new plugin at https://plugins.jetbrains.com/plugin/7740?pr=phpStorm.

What version of the plugin are you currently running? It should say in the Plugin Preferences within WebStorm.

The most recent version of the plugin, 0.3.323 should expire in early July to coincide with our commercial release of the plugin.