PDA

View Full Version : Can Eclipse Plugin 2.1.0.57 be used with ExtJS 6.0



DougCyporyn
10 Sep 2015, 5:43 AM
Hello, I'm new to Sencha. I'm mainly a Java Developer. I'm very much accustomed to using Eclipse. I have the Eclipse Plugin version 2.1.0.57 installed. Following the instructions with the download package, it seems that the latest type libraries available are for version 4.2 of the Ext JS framework. However, we are interested in developing with the Ext JS 6.0 framework. Is the Eclipse plugin usable with version 6.0 of the Ext JS? Thanks in advance!

Doug

tristan.lee
11 Sep 2015, 10:36 PM
Unfortunately, the type libraries are only available for Ext JS 4.0.7, 4.1, and 4.2. If you use it for other versions for Ext, not all classes will be available and some will may no longer apply due to framework changes.

DougCyporyn
12 Sep 2015, 3:28 PM
Thanks Tristan. After using both Eclipse Plugin and JetBrains plugin, it seems pretty clear that JetBrains is more straightforward.