PDA

View Full Version : Getting VBox error



ttbgwt
10 Sep 2015, 11:23 AM
I let the plugin auto-add some requires, including those for type: 'vbox', but then I see error as shown in image below indicating unused class. If I remove it, then I get message back to add it...

53220

Mark.Brocato
14 Sep 2015, 6:10 AM
Based on that error I'm guessing the problem is that you have both Sencha Touch and Ext JS apps in your project, so the plugin is trying to resolve classes from both and getting confused. To fix this you need to add each SDK as a library and define scopes. See http://docs.sencha.com/ide_plugins/jetbrains_ide_plugin.html#Projects_with_both_Sencha_Touch_and_Ext_JS