PDA

View Full Version : [OPEN] Glibc 2.15 and 2.14 required on Linux



bartyhoho
4 Nov 2015, 7:02 AM
I received error messages when trying to create a new Sencha Project app and adding a Sencha Nature to an existing Dynamic Web Project. Both indicated glibc 2.15 and 2.14 was required. System is Oracle Linux 6.7 x64.

It would be more helpful if the dependency check could be performed during the plugin installation.

Here's the error message:

Tern process ended unexpectedly with exit code 1 on port 51315 for /home/XXX/workspace/SenchaTest

Sencha Ext JS autocompletion will be disabled
/home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)
/home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)

Chris.OBrien
4 Nov 2015, 8:59 AM
I received error messages when trying to create a new Sencha Project app and adding a Sencha Nature to an existing Dynamic Web Project. Both indicated glibc 2.15 and 2.14 was required. System is Oracle Linux 6.7 x64.

It would be more helpful if the dependency check could be performed during the plugin installation.

Here's the error message:

Tern process ended unexpectedly with exit code 1 on port 51315 for /home/XXX/workspace/SenchaTest

Sencha Ext JS autocompletion will be disabled
/home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.15' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)
/home/XXX/.local/share/data/Sencha/EclipsePlugin/tern: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/XXX/.local/share/data/Sencha/EclipsePlugin/tern)

From http://www.oracle.com/us/technologies/linux/product/specifications/index.html it looks like Oracle Linux 6.5 has glibc 2.11, so I'm assuming 6.7 has somewhere between 2.11 and 2.13.

Can you run the following command in the command line, which will display what glibc version you have?


ldd --version

Our plugin install can't check for the glibc version, since this is a background process launched separately from the plugin. It's compiled for each OS, but must have been compiled with a newer version of glibc.

bartyhoho
4 Nov 2015, 9:45 AM
I have 2.12.

Chris.OBrien
4 Nov 2015, 10:15 AM
I have 2.12.

From my understanding, there was a large jump between 2.13 and 2.14. 2.12 was released in 2010, so it's unfortunate that even you're on a relatively new version of Oracle Linux, it's got an old glibc.

I'm not sure if we'll be able to easily support older versions of glibc, but I'll create a ticket to track this issue for future evaluation.

In the meantime, are you able to run on a different machine to evaluate, or potentially run VirtualBox with a different linux distro, like Ubuntu?

bartyhoho
4 Nov 2015, 10:28 AM
Yeah, I was afraid of that. I am running on a VM, so I can try playing around to see what happens. I'll post with results if I get something working.