PDA

View Full Version : [NOREPRO] [E] [Ext.Loader] Some requested files failed to load. in MVC structure



s0165
16 Nov 2015, 8:29 PM
Hi I tried to create a MVC project in sencha fiddle.

After I click the run fiddle, the browser show me some error messages
GET https://fiddle.sencha.com/Fiddle/store/ListViewStore.js?_dc=1447733834495 404 (Not Found)
[E] [Ext.Loader] Some requested files failed to load.
Uncaught TypeError: Cannot read property 'isBufferedStore' of undefined

How to fix this problem? Thanks

my code as below and the fiddle (https://fiddle.sencha.com/#fiddle/113k)
app.js


Ext.application({
name: 'Fiddle',
appFolder: 'app',
autoCreateViewport: true,
store: ['ListViewStore'],
launch: function() {
}
});


Viewport.js


Ext.define('Fiddle.view.Viewport', {
extend: 'Ext.container.Viewport',
layout: 'border',
requires: ['Fiddle.view.ListView'],
items: [{
region: 'center',
xtype: 'listview',
}]
});


view


Ext.define('Fiddle.view.ListView', {
extend: 'Ext.grid.Panel',
alias: 'widget.listview',
title: 'MVC Grid Sample',
store: 'ListViewStore',
columns: [
{ text: 'Name', dataIndex: 'name' },
{ text: 'Email', dataIndex: 'email', flex: 1 },
{ text: 'Phone', dataIndex: 'phone' }
],
height: 200,
width: 400,
initComponent: function() {
var me = this;
me.callParent(arguments);
}
});


model


Ext.define('Fiddle.model.ListViewModel', {
extend: 'Ext.data.Model',
fields: ['name', 'email', 'phone'],
});


store


Ext.define('Fiddle.store.ListViewStore', {
extend: 'Ext.data.Store',
model: 'Fiddle.model.ListViewModel',
data:{'items':[
{ 'name': 'Lisa', "email":"lisa@simpsons.com", "phone":"555-111-1224" },
{ 'name': 'Bart', "email":"bart@simpsons.com", "phone":"555-222-1234" },
{ 'name': 'Homer', "email":"homer@simpsons.com", "phone":"555-222-1244" },
{ 'name': 'Marge', "email":"marge@simpsons.com", "phone":"555-222-1254" }
]},
proxy: {
type: 'memory',
reader: {
type: 'json',
rootProperty: 'items'
}
}
});


controller


Ext.define('Fiddle.controller.ListViewController', {
extend: 'Ext.app.Controller',
stores: ['ListViewStore'],
init: function() {
var me = this;
me.control({
'listview': {
itemdblclick: me.dbClickIconView
}
});
},
dbClickIconView: function(me, record, item, index, e) {
console.log(record);
}
});

s0165
17 Nov 2015, 6:57 PM
I got the solution. The store config miss 's' in app.js. It should be 'stores'
Now it works and I have updated the fiddle.

Thanks all.

Gary Schlosberg
18 Nov 2015, 10:49 AM
Yep, that would cause problems. I'm glad it's working for you and thanks for following up here.

mitchellsimoens
19 Nov 2015, 12:40 PM
It's also important to note that the files in fiddle are fake files, they do not live on any filesystem nor can you load them via any URL. This is important as if a class requires another class that is not yet loaded, Ext JS will try to load that required class via a URL. So in fiddle, don't use requires/uses/Ext.Loader.require or the like. app.js will be executed after all other JS fake files.

razvanioan
20 Dec 2015, 3:42 AM
The sequence of the "files" it's also important !

I had defined a Base and Actor models, and it was always throwing errors about missing Base.js until I have swapped the order of them in the resources panel: Base had to be first !