PDA

View Full Version : 6.0.7 won't install in IDEA 16 EAP



dmurat
8 Jan 2016, 11:39 AM
Just released 6.0.7 version does not work with idea 16 EAP (build 144.2608.2), although it should be, at least according to
https://www.sencha.com/forum/showthread.php?307406-Please-do-not-upgrade-to-IntelliJ-15.0.2-WebStorm-11.0.2-etc...&p=1124439&viewfull=1#post1124439
(https://www.sencha.com/forum/showthread.php?307406-Please-do-not-upgrade-to-IntelliJ-15.0.2-WebStorm-11.0.2-etc...&p=1124439&viewfull=1#post1124439)
When trying to install, I'm getting "Plugin 'Sencha Ext JS' is incompatible with this installation".

Is it just temporary issue or something more serious?

Tnx.

Mark.Brocato
8 Jan 2016, 1:06 PM
Right now it doesn't work in 16 EAP only because I explicitly marked it as only valid for 15. I did this because history shows that changes tend to happen late in JetBrain's EAP cycle. This way if they introduce breaking changes late in the 16 EAP, users won't try to upgrade and then get a broken Ext JS plugin again. This way they will at least get warned that the Ext JS plugin isn't compatible. If 16 doesn't introduce breaking changes upon release I was planning to just issue a trivial 6.0.8 release that's marked as compatible with 16.

On second thought this might be more trouble than it's worth...

dmurat
8 Jan 2016, 1:30 PM
Yes, it looks like somewhat unnecessary hassle since JetBrains did change API in minor release. I'm eager to try it with 16 EAP since it implements some significant improvements for Gradle builds. So I'm asking you if you can consider your decision, since otherwise these IDEA features will be unavailable to Sencha plugin users until JetBrains releases version 16 which might be months from now. Anyway, if you release early, feedback will be much more faster :-)

Tnx for your efforts.

dmurat
27 Jan 2016, 3:16 PM
Thank you for reenabling support for IDEA 16 EAP with latest 6.0.8 release :-)

Mark.Brocato
27 Jan 2016, 4:37 PM
No problem. It does look like code completion is a little funny in 16 EAP. It tends to only show recently used choices in certain cases. I've got a fix in for it and we will most likely release 6.0.9 to address this in the next few weeks.

dmurat
28 Jan 2016, 10:22 AM
It looks like inspections also have some problems. I.e. "missing in requires array" is not working as in IDEA 15. Are you interested for such reports, or should I wait with them until some point in the future when IDEA 16 will be more stable?

Mark.Brocato
28 Jan 2016, 11:03 AM
Yes, please let us know about anything you run into. It will certainly help us track down and fix issues.