PDA

View Full Version : [INFOREQ] Font colour is not wotking correctly in INTERNET EXPLORER TEXT EDITOR



meenakhshi
10 Mar 2016, 3:54 AM
If we place the cursor before the some earlier written text it will work fine but when we place the cursor after some text it will not function and thus we will not be able to write colorful text.This is only reproducible in IE.This is happening in Ext js 4..2.2 version.

Gary Schlosberg
10 Mar 2016, 8:20 AM
Thanks for the report. Can you please post a test case which reproduces this issue?
https://fiddle.sencha.com/#home

meenakhshi
10 Mar 2016, 9:26 PM
This the code of html editor...

Ext.tip.QuickTipManager.init(); // enable tooltips
Ext.create('Ext.form.HtmlEditor', {
width: 580,
height: 250,
renderTo: Ext.getBody()
});

Ext JS 4.2.0.663 Classic version..
it reproduces the case..

Gary Schlosberg
14 Mar 2016, 3:25 PM
I added your test case to this Fiddle.
https://fiddle.sencha.com/#fiddle/1757

I tried it out with Windows 8.1 but it works as expected -- setting a font color changes subsequent text typed. With which version of Windows are you seeing this?

meenakhshi
4 Apr 2016, 3:01 AM
Hii..i m using windows 7

Gary Schlosberg
4 Apr 2016, 3:24 PM
Tried with Windows 7 (IE11), but I'm still not seeing it. With which version of Internet Explorer are you seeing this?

meenakhshi
4 Apr 2016, 9:05 PM
I am using IE11, Windows 7,Ext JS 4.2.0.663 Classic version in fiddle and it reproduces the case.

Gary Schlosberg
5 Apr 2016, 1:17 PM
I am testing with the same configuration and I'm not able to recreate the issue. Are you able to recreate using the test case (https://fiddle.sencha.com/#fiddle/1757) I posted, or are you only seeing this within your application? If so, does it still occur with newer versions of Ext JS?

meenakhshi
5 Apr 2016, 9:15 PM
Hi, Place the cursor after and before some earlier written text in the editor,this should replicate the case.This is happening only for this version of Ext js.

Gary Schlosberg
6 Apr 2016, 10:50 AM
I think I see the issue now. When the cursor is after some text, changing the color moves the cursor to the beginning of the line. The color is applied, but new text is in the wrong place. I see this issue in 4.2.0 through 4.2.2, but it was fixed in 4.2.3. Are you able to test your application with that version to confirm?

meenakhshi
6 Apr 2016, 9:11 PM
Yes for updated version issue is not reproducible.