PDA

View Full Version : What files do I need to get started using yui-ext ?



valc
25 Oct 2006, 10:57 AM
I have tried to use the code from some of the examples but I keep getting errors. What files do I need to have included in my page to start using the yui extension ? I have also search the forumn but I cannot see an example.

norman64
25 Oct 2006, 12:40 PM
You'll need to include your "usual" Yahoo! UI files (yahoo.js,event.js,dom.js,dragdrop.js,animation.js) for the Yahoo library to work. And for the ext you just need the yui-ext.js

valc
25 Oct 2006, 1:09 PM
Thanks for that Norman. Does the yui-ext file contain everything for Jack's examples to work ?

jack.slocum
25 Oct 2006, 4:20 PM
Yes, yui-ext.js is the big one. It has everything in yui-ext.

valc
26 Oct 2006, 1:29 AM
I have used code from http://www.jackslocum.com/blog/examples/layout-tim.htm but I get an error on the following line ...

var layout = new YAHOO.ext.BorderLayout. I have included the following files...

<script type="text/javascript" src="yui/yahoo/yahoo.js"></script>
<script type="text/javascript" src="yui/event/event.js"></script>
<script type="text/javascript" src="yui/dom/dom.js"></script>
<script type="text/javascript" src="yui/dragdrop/dragdrop.js"></script>
<script type="text/javascript" src="yui/animation/animation.js"></script>
<script type="text/javascript" src="yui/connection/connection.js"></script>
<script type="text/javascript" src="yui/container/container.js"></script>

<script type="text/javascript" src="yui-ext.js"></script>
<script type="text/javascript" src="ie-bg.js"></script>
<script type="text/javascript" src="util.js"></script>

and reset-min.css, tabs.css, layout.css. The version of the extension is yui-ext.32.3.1. Do i need to have all the yui-ext.32.3.1 directory in the path or just the yui.ext.js file ?

I can post the html if you like? What could be wrong ?I think if i get the basics setup properly I will be able to use all the other examples. By the way, great work.

jack.slocum
26 Oct 2006, 7:52 AM
BorderLayout isn't in 0.32.3.1. It new for .33 and hasn't been included in the standard download yet. Everyone has been using my dev copy of the new version.

valc
26 Oct 2006, 7:55 AM
Aha ! I'll have a look at that now so.