PDA

View Full Version : [FIXED] Fuzzy search



pmiklashevich
23 Jun 2016, 2:24 AM
New API docs search doesn't work correctly. When type 'xtemplate' or 'componentQuery' search doesn't have a result. Need to write starting from the beginning like 'ext.xtemplate' or 'ext.componentQuery'. It can be hard because you have to remember full name of what you are trying to find.


Also it would be nice to have key navigation for the result, like it was in old version. And open selected item by Enter. Also it would be nice to have an option to open in new browser tab by Shift+Enter since new API docs don't have tabs any more.

ebarber
23 Jun 2016, 4:45 AM
What browser are you using? I'm using chrome and hitting Tab cycles through the search results, then hitting enter opens that one, while hitting Shift+Enter opens it in a new window.

pmiklashevich
23 Jun 2016, 5:18 AM
I'm using chrome on macbook (OS X El Capitan). Tab button works for "API Docs" column. For "GUIDES" it doesn't work. It changes focus instead of selection, so it doesn't loop through search result. For quick workaround it's OK to use Tab then Enter. But arrows navigation would be nice (up, down, left, right). Shift+Enter opens new tab in new chrome window at least on macbook, so it's not so useful. And main question is still open: search doesn't work correctly.

slemmon
24 Jun 2016, 2:31 PM
Thanks for the report! The bug of not being able to search for a classname without first entering the namespace (i.e. searching for "ext.string" -vs- just "string") got fixed today and will be pushed to production in another day or two as we collect up a few more fixes. Sorry for the confusion there.

Improved keyboard navigation within the search results is something we've got on our internal To-Do list. Keep an eye out for future improvements as the docs software evolves. Keep the ideas coming!