PDA

View Full Version : Sencha cmd Issue with Sencha Themer



MikeRH
23 Jun 2016, 8:35 AM
Themer has a requirement of cmd 6.2.0 which means that if I want the theme to work using sencha app build, my app must be created with cmd 6.2.0. However when I use cmd 6.2.0 I get the following warnings during the app creation and builds.

[WRN] @theme-background-image: Theme image not found: images/loadmask/loading.gif
[WRN] @theme-background-image: Theme image not found: images/tools/tool-sprites.png
[WRN] @theme-background-image: Theme image not found: images/tools/tool-sprites-dark.png
[WRN] @theme-background-image: Theme image not found: images/tools/tool-sprites-dark.png
[WRN] @theme-background-image: Theme image not found: images/form/exclamation.png
[WRN] @theme-background-image: Theme image not found: images/form/exclamation.png
[WRN] @theme-background-image: Theme image not found: images/tools/tool-sprites-dark.png
[WRN] @theme-background-image: Theme image not found: images/tools/tool-sprites-dark.png
[WRN] @theme-background-image: Theme image not found: images/form/exclamation.png
[WRN] @theme-background-image: Theme image not found: images/grid/dd-insert-arrow-right.png
[WRN] @theme-background-image: Theme image not found: images/grid/dd-insert-arrow-left.png
[WRN] @theme-background-image: Theme image not found: images/grid/col-move-top.png
[WRN] @theme-background-image: Theme image not found: images/grid/col-move-bottom.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-group-checked.png
[WRN] @theme-background-image: Theme image not found: images/tools/tool-sprites-dark.png
[WRN] @theme-background-image: Theme image not found: images/breadcrumb/default-arrow.png
[WRN] @theme-background-image: Theme image not found: images/breadcrumb/default-arrow-rtl.png
[WRN] @theme-background-image: Theme image not found: images/breadcrumb/default-arrow-open.png
[WRN] @theme-background-image: Theme image not found: images/breadcrumb/default-arrow-open-rtl.png
[WRN] @theme-background-image: Theme image not found: images/breadcrumb/default-scroll-left.png
[WRN] @theme-background-image: Theme image not found: images/breadcrumb/default-scroll-right.png
[WRN] @theme-background-image: Theme image not found: images/tree/loading.gif
[WRN] @theme-background-image: Theme image not found: images/tree/loading.gif
[WRN] @theme-background-image: Theme image not found: images/window/toast/icon16_info.png
[WRN] @theme-background-image: Theme image not found: images/window/toast/icon16_error.png
[WRN] @theme-background-image: Theme image not found: images/window/toast/fader.png


What is the workaround for this issue?

sandeep.adwankar
23 Jun 2016, 8:41 PM
Hi!
You should ignore these warnings; they should not have effect in using Sencha Themer. Did you encounter any issue with creating theme using Sencha Themer?Thanks!

MikeRH
24 Jun 2016, 6:43 AM
It may not matter to themer but does it matter for the application? Those warnings are from sencha generate app --classic Test test.

kkrohe
29 Jun 2016, 10:01 AM
It should be ok to ignore those warnings. They are generated by a Cmd bug that was not properly checking the filesystem for presence of those files. The files are there, Cmd is just generating a bad warning.

That bug was resolved after the EA release, so the next Cmd 6.2 release will have those cleared up.

MikeRH
1 Jul 2016, 11:05 AM
That's great, thanks for following up.

tellioglu
9 Sep 2016, 11:23 PM
I did an upgrade of my application from ExtJS 6.0.2 to ExtJS 6.2 and I am still getting the following warnings from Cmd 6.2:



[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-checked.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-unchecked.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-group-checked.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-menu-parent-left.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-scroll-top.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-scroll-bottom.png


Does this mean that the bug is still there? How can I get rid of these warnings?

Thanks,
Horst

gabendaq
12 Sep 2016, 7:38 AM
I have just upgraded to 6.2.0 also and am encountering these warnings:



[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-group-checked.png

gwt
20 Oct 2016, 5:34 AM
I also get some warnings, when I compile my applications. I am using Sencha Cmd 6.2.0.103:


[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-checked.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-unchecked.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-group-checked.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-scroll-top.png
[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-scroll-bottom.png
[WRN] @theme-background-image: Theme image not found: images/tab/tab-navigation-close.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-scroll-left.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-scroll-right.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-scroll-top.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-scroll-bottom.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-more.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-plain-scroll-left.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-plain-scroll-right.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-plain-scroll-top.png
[WRN] @theme-background-image: Theme image not found: images/tab-bar/navigation-plain-scroll-bottom.png

[WRN] @theme-background-image: Theme image not found: images/menu/default-menubar-menu-parent-left.png


Currently I don't have any problems in the apps, they all work and images are displayed correctly.