PDA

View Full Version : Upgrading ExtJS from 4.1.3 to 4.2.5.1763



cmeans
29 Jun 2016, 11:07 AM
I'm currently using Sencha Cmd v3.0.2.288 to build my ExtJS 4.1.3 app. I need to upgrade to 4.2.x to address a bug that's fixed in that later version.

However, I note that ExtJS 4.2.4 (and later in the 4.2 range) requires Sencha Cmd v4.0.5.

Does this mean I just need to install Cmd 4.0.5 and perform the upgrade as normal? (seems like that might not work.)

Any help would be appreciated.

Thanks.

Gary Schlosberg
30 Jun 2016, 7:04 AM
According to the compatibility matrix, you should install the most up-to-date version of Cmd as this will still run 4.1.1.
http://docs.sencha.com/cmd/guides/compatibility_matrix.html

First of all, be sure to back up your project before making any changes. I would install the latest Cmd and try to build your 4.1.3 project. Once that is successful, I would then upgrade the framework to 4.2.5.