PDA

View Full Version : Can't found test scenario when running Sencha Test by CLI



LVarayut
29 Jul 2016, 3:30 AM
Hi All,

I have a simple app sencha generated from command "sencha -sdk /path/to/extjs/framework generate app AppName path/to/app".
In the Sencha Studio, I can run these test scenarios successfully, but when I tried by using CLI, it didn't work.

I followed the guides to install the nodejs and config the PATH for stc.

When runing following command:

stc run -o text -p "chrome" -s AppName\test\uiTest

I got the error:

No test scenario found on <path to \AppName\test\uiTest>

I also tried solutions according to https://www.sencha.com/forum/showthread.php?309422-Running-tests-of-packages-in-CLI,
but still does not work.

Any suggestion?

vojtech.cerveny
29 Jul 2016, 5:25 AM
Hi,
I think that your path is not correct. Try



cd yourApp
stc run -o text -p "chrome" -s test/uiTest


If you want be sure, you can run test from scenario folder and forget parameter "-s"



cd yourApp/test/uiTest
stc run -o text -p "chrome"


I hope that will help you.

Fell free to contact me any time.
Vojt?ch

LVarayut
2 Aug 2016, 7:31 PM
Hi vojtech.cerveny,

I've tried but still not resolved.
Here is my example : https://drive.google.com/file/d/0B7ltPSrmxjgFWmRFNEpFRVJHVGs/view?usp=sharing
(https://drive.google.com/file/d/0B7ltPSrmxjgFWmRFNEpFRVJHVGs/view?usp=sharingPlease)Please help me check my example missing any config?


Thanks for the reply.

UPDATE

I have tried this one https://www.sencha.com/blog/using-sencha-test-with-jenkins-and-selenium-grid/, and it works.
Thank vojtech.cerveny.