PDA

View Full Version : No preview on SA web server for upgraded XDS project?



h.koch
20 Oct 2016, 7:20 AM
Hello,

I've upgraded an existing project (created in SA3.2 with ExtJS4.x) with SA4.0 to ExtJS5, then EXT6 and then EXT6.2. The resulting project has a preview functionality which points to my local webserver (running on Mac OS X, default port 80), but doesn't provide an option for running the internal web server (which is working for newly created projects with the same classic toolkit). Is there anything wrong with the migrated project?
Furthermore, the project does publish old code after saving, building and publishing. I just removed a "console.log" from a test function, but this console.log re-appeared in both test and production builds. I assume no updated code is being deployed (even after completely deleting the deploy target directory, which is then successfully recreated).
I'm running SA4.0.2 build 209 on Mac OS 10.11.6.

petr.vecera
20 Oct 2016, 8:50 AM
Hello,

I've upgraded an existing project (created in SA3.2 with ExtJS4.x) with SA4.0 to ExtJS5, then EXT6 and then EXT6.2. The resulting project has a preview functionality which points to my local webserver (running on Mac OS X, default port 80), but doesn't provide an option for running the internal web server (which is working for newly created projects with the same classic toolkit). Is there anything wrong with the migrated project?
Furthermore, the project does publish old code after saving, building and publishing. I just removed a "console.log" from a test function, but this console.log re-appeared in both test and production builds. I assume no updated code is being deployed (even after completely deleting the deploy target directory, which is then successfully recreated).
I'm running SA4.0.2 build 209 on Mac OS 10.11.6.

Hi

For the preview try to open you project settings and in the url prefix put this:
http://localhost:{port}/{path}

So it looks like this:
55337

The app watch server should be running automatically for you. You can also check the output tab in the SA. You should be able to see that the app watch is running on some port.



I assume no updated code is being deployed (even after completely deleting the deploy target directory, which is then successfully recreated).

Please try to do some bigger change. For example add new panel / button and save and preview the build. It's possible that the console log is on more places in your project. You can also try to search your project for the console.log.

Regards
Petr

h.koch
20 Oct 2016, 11:29 AM
Hi Petr,


Hi

For the preview try to open you project settings and in the url prefix put this:
http://localhost:{port}/{path}

So it looks like this:
55337

The app watch server should be running automatically for you. You can also check the output tab in the SA. You should be able to see that the app watch is running on some port.

This was already configured, interestingly, the preview URL doesn't contain such a port information (despite a new empty project has this information):

55338



Please try to do some bigger change. For example add new panel / button and save and preview the build. It's possible that the console log is on more places in your project. You can also try to search your project for the console.log.

Doesn't work either. I suspect this message in the logs is the reason for many misbehaviours:


Exception in thread "Thread-44" com.sencha.exceptions.BasicException: com.sencha.exceptions.ExState: Unable to load required framework: null@6.2.0.981


Ext62 is contained in the directory configured in "Sencha Architect" -> "Preferences" -> "File" -> "Frameworks" with exact this version (6.2.0.981). Weird.

h.koch
20 Oct 2016, 11:51 AM
I managed to resolve the preview issue: the app.json file was missing the following line (hopefully this information is helpful for others):


"framework": "ext",

Unfortunately, there are more missing entities like themes. Working on them....

h.koch
20 Oct 2016, 1:42 PM
After editing .sencha/app/sencha.cfg (updating to latest ExtJS version) and running


sencha app upgrade -ext
sencha app upgrade

followed by re-setting the theme, editing app.json (with the same values as in a new classic toolkit project), the project successfully builds.