PDA

View Full Version : Store Error "The data config needs to be an array of data objects."



carl23934
29 Nov 2016, 8:02 AM
When I have a store with the "data" property set, and I use an array of arrays, I see this error:
"The data config needs to be an array of data objects."

However everything works just fine since this is perfectly valid. I do not want to use an array of objects since I don't have to. An array of arrays is the most efficient way to store this data.

My app works just fine, it's annoying that architect doesn't agree.

I noticed this has been an architect bug for quite some time, at least since 3.5.

Can anything be done to make this go away?

55566