PDA

View Full Version : [FIXED] Align issue on grid columns and tree columns



Alessio Brunello
19 Dec 2016, 6:38 AM
I've an application with a tree panel like menu, the align property of the columns is left as default, and the builded project seems to be perfect, but architect preview shows me all the aligns on the right.

Issue also on grid columns.

How can i fix it? :-?

With the same code, thats the preview

55668

and that's the production build

55669

The problem started on SA 4.0.2 and is continuing updating to 4.1



Version:
4.1.0.91





Channel:
4.1-stable





Platform:
1.2.8.3 - win32 x64





Renderer:
51.0.2704.106





Cmd:
6.2.1.29





Framework:
Ext JS 6.2.x Classic

petr.vecera
19 Dec 2016, 7:22 AM
Hello

This should be already fixed. Could you please post the code of your class?

Are you able to reproduce this issue from the new project? There might be just cached old files in your project.

Thank you
Petr

Alessio Brunello
19 Dec 2016, 7:35 AM
Just tried and with a new project nothing goes wrong, but how can i do for the main project? thats really big

Here is code of the treepanel


{
xtype: 'treepanel',
flex: 1,
floatable: false,
region: 'west',
split: true,
reference: 'treeattivita',
id: 'treeattivita',
maxWidth: 350,
scrollable: true,
width: 150,
collapseDirection: 'left',
collapsible: true,
title: 'Attività',
hideHeaders: true,
lines: false,
rootVisible: false,
useArrows: true,
bind: {
store: '{AttivitaStore}'
},
viewConfig: {
selectedItemCls: 'x-grid-item-selected boldchar',
markDirty: false,
rootVisible: false
},
columns: [
{
xtype: 'treecolumn',
flex: 1,
dataIndex: 'text'
},
{
xtype: 'templatecolumn',
tpl: [
'<tpl if=\'page=="mystato" && numero!=""\'><div class="badge-rosso">{numero}</div></tpl>',
'<tpl if=\'page=="myerrorlog" && numero!=""\'>{numero}</tpl>'
],
width: 50,
dataIndex: 'numero'
}
],
listeners: {
select: 'onTreepanelSelect'
}
}

petr.vecera
19 Dec 2016, 8:03 AM
I see. First try to click on the compile CSS button (right bottom corner of SA) in the SA if it doesn't help:

Try to delete files in this folder:
<projectRoot>/resources

You can also try to delete
<projectRoot>/build

Let me know if it helped you.

Petr

Alessio Brunello
23 Dec 2016, 6:04 AM
Your process didn't work for me, i really need to create a new project and copy paste it?

petr.vecera
23 Dec 2016, 8:25 AM
This issue was introduced in SA 4.0.0 and should be fixed from SA 4.0.1 (http://docs.sencha.com/architect/4/guides/reference/change_log.html#reference-_-change_log_-_version_4_0_1) where it was fixed using SA overrides and it should be completely fixed in SA 4.1 where ExtJS 6.2.1 (this is Ext bug) is used.

When I created project in SA 4.0.0 where the TreePanel is broken and than opened it in SA 4.1 it's OK.

Are you sure that you deleted files like:
<projectFolder>\resources\.arch-internal-preview (this is the CSS used inside SA)
and
<projectFolder>\resources\preview-theme-triton-a0748619-f7e3-4048-acb1-806c0d8b79ed.css

^^ these are the files for the design view in SA

And you also deleted files like:
<projectFolder>\build\development\MyApp\resources

^^ these are the files for the app watch preview.

Well if you really deleted these folder and it didn't help you. You can try to save project as to a new folder location. You can try to create project archive and than open it and save it to a new folder and you can also try to delete this folder C:\Users\<user>\AppData\Local\Sencha\Sencha Architect 4.0\extracted (delete that folder when SA is off)

Also can you try to apply new theme to you project? Let's see if it helps.

Alessio Brunello
23 Dec 2016, 9:21 AM
I will try these new suggestions, ty and happy christmas!!

Alessio Brunello
26 Dec 2016, 11:48 PM
Tried all, but nothing goes right, I'll open a new project and try to transfer it :((