PDA

View Full Version : Problems upgrading from extj 5.1 to Extjs 6.2 with architect 4.1



kimsreng1
20 Dec 2016, 4:43 PM
After the upgrade, all views, models, and stores are not visible in project inspector. Does anyone have the same problem? any solution?

grosst
20 Dec 2016, 6:01 PM
After the upgrade, all views, models, and stores are not visible in project inspector. Does anyone have the same problem? any solution?


there has to be a broken link somewhere in there. The different scenarios that run through my head from going from 4.0 all the way to 6.2 within the same SA app would make your head spin.

Let's start small here -

is it a column chart? that's busted in SA41. Reconfigure it using a Bar chart
Have you looked at the 5x -> 6 upgrade guides?

http://docs.sencha.com/extjs/6.0.1/guides/upgrades_migrations/extjs_upgrade_guide.html
5x was precursor to 6. Giving you responsive configs, MVVM, etc. Prepping you for the adaptive design abilities of universal applications.


is it all your panels?
How big is your project?
Have you looked at the debug log?

Without seeing anything, it's really hard to see what's going on. So you're going to have to be more descriptive with the issue you'er experiencing.

Anyway, the above is a good place to start.

kimsreng1
20 Dec 2016, 9:51 PM
there has to be a broken link somewhere in there. The different scenarios that run through my head from going from 4.0 all the way to 6.2 within the same SA app would make your head spin.

Let's start small here -

is it a column chart? that's busted in SA41. Reconfigure it using a Bar chart
Have you looked at the 5x -> 6 upgrade guides?

http://docs.sencha.com/extjs/6.0.1/guides/upgrades_migrations/extjs_upgrade_guide.html
5x was precursor to 6. Giving you responsive configs, MVVM, etc. Prepping you for the adaptive design abilities of universal applications.

is it all your panels?
How big is your project?
Have you looked at the debug log?

Without seeing anything, it's really hard to see what's going on. So you're going to have to be more descriptive with the issue you'er experiencing.

Anyway, the above is a good place to start.

Thank you so much. I'll check it again.

petr.vecera
21 Dec 2016, 1:27 AM
Hello

Please check if this issue doesn't concern you https://www.sencha.com/forum/showthread.php?333519-Failed-upgrade-from-4-0-to-4-1&p=1168527&viewfull=1#post1168527

Also please check if you create new project ext62 from template or something - if you see the things in the project inspector.

Thank you
Petr

kimsreng1
21 Dec 2016, 10:55 AM
Hello

Please check if this issue doesn't concern you https://www.sencha.com/forum/showthread.php?333519-Failed-upgrade-from-4-0-to-4-1&p=1168527&viewfull=1#post1168527

Also please check if you create new project ext62 from template or something - if you see the things in the project inspector.

Thank you
Petr
Thank you so much. It really fixed... !