PDA

View Full Version : Installation Problem



mjcee
5 Jan 2017, 12:42 PM
I am having trouble installing Visual Studio Code Plugin. I have Visual Studio Code Version 1.8.1 dated 2016-12-19 installed on the system. When I run the installer, I get an Installation Failed message.. Below is the install log. What am I missing?

[CODE]
1/5/2017 3:38:42 PM - Microsoft VSIX Installer
1/5/2017 3:38:42 PM - -------------------------------------------
1/5/2017 3:38:42 PM - Initializing Install...
1/5/2017 3:38:43 PM - Extension Details...
1/5/2017 3:38:43 PM - Identifier : vscode-extjs
1/5/2017 3:38:43 PM - Name : Sencha Ext JS
1/5/2017 3:38:43 PM - Author : Sencha
1/5/2017 3:38:43 PM - Version : 1.0.0
1/5/2017 3:38:43 PM - Description : Provides code completion for Sencha Ext JS
1/5/2017 3:38:43 PM - Locale : en-US
1/5/2017 3:38:43 PM - MoreInfoURL :
1/5/2017 3:38:43 PM - InstalledByMSI : False
1/5/2017 3:38:43 PM - SupportedFrameworkVersionRange : [0.0,2147483647.2147483647]
1/5/2017 3:38:43 PM -
1/5/2017 3:38:44 PM - SignatureState : Unsigned
1/5/2017 3:38:44 PM - Supported Products :
1/5/2017 3:38:44 PM - Microsoft.VisualStudio.Code
1/5/2017 3:38:44 PM - Version :
1/5/2017 3:38:44 PM -
1/5/2017 3:38:44 PM - References :
1/5/2017 3:38:44 PM - Signature Details...
1/5/2017 3:38:44 PM - Extension is not signed.
1/5/2017 3:38:44 PM -
1/5/2017 3:38:44 PM - Searching for applicable products...
1/5/2017 3:38:44 PM - Found installed product - Microsoft Visual Studio 2010 Professional
1/5/2017 3:38:44 PM - Found installed product - Microsoft Visual Studio Professional 2013
1/5/2017 3:38:44 PM - Found installed product - Microsoft Visual Studio 2013 Shell (Integrated)
1/5/2017 3:38:44 PM - Found installed product - Microsoft Visual Studio Community 2015
1/5/2017 3:38:44 PM - Found installed product - Microsoft Visual Studio 2015 Shell (Integrated)
1/5/2017 3:38:44 PM - Found installed product - Global Location
1/5/2017 3:38:44 PM - VSIXInstaller.NoApplicableSKUsException: This extension is not installable on any currently installed products.
at VSIXInstaller.App.InitializeInstall(Boolean isRepairSupported)
at VSIXInstaller.App.InitializeInstall()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()


[/CODE/

Mark.Brocato
11 Jan 2017, 7:33 AM
I think by "running" the installer windows is trying to install the Visual Studio Code plugin in Visual Studio, probably because they both use the same vsix extension. You're supposed to install the extension from within Visual Studio Code. See the instructions here:

http://docs.sencha.com/ide_plugins/guides/visual_studio_code_ide_plugin.html#visual_studio_code_ide_plugin_-_installing_from_the_support_portal

ithompson
1 Feb 2017, 10:05 AM
I ran into the exact same issue - the extension could not find my VSCode installation. Marc's suggestion worked for me.