PDA

View Full Version : File Watcher Problem



mlmcconnell
24 Jan 2017, 2:23 PM
I recently copied an entire project folder onto my development file server (a Virtual Machine that runs on my development laptop) so that I could test my applications without having to build/deploy every time I update my application code (the application depends on a ColdFusion backend so it must be run from an appropriate web directory in IIS). The first time, and all subsequent times, I opened the Sencha Architect project file, I received the following error message:

Uncaught Error: Error watching file for changes: UNKNOWN

If I click the ignore button in the error dialog box anywhere from 35 to 96 times, the project will eventually open in SA. If I disable file watcher in the SA preferences, the project opens with no errors. Any idea what could be causing this? I've made sure the file access settings are correct and once I disable file watcher SA operates (saves/builds/deploys) as expected.

Note: I access the SA project by "mapping a network drive" to the administrative share of the virtual file server so that my dev environment sees it as a mapped network drive: "v:\inetpub\wwwroot\dev\projectfolder". Don't know if that makes a difference, but thought I'd include this for completeness.

Another Note: I noticed that when running the application from the root of the project directory, all the columns in my data grids are right-aligned now. They are aligned correctly after the project is compiled and deployed. Is there a setting I'm missing?

petr.vecera
24 Jan 2017, 2:59 PM
Not sure what that error is. You are doing it right by mapping network drive. As UNC (\\Server\Volume\File ) paths are not supported. But you can keep the file-watcher disabled. It can detect outside changes of the project important files and also re-checks if the files are correctly written to the disk. So you should be able to work without any problems with disabled file watcher.



Another Note: I noticed that when running the application from the root of the project directory, all the columns in my data grids are right-aligned now. They are aligned correctly after the project is compiled and deployed. Is there a setting I'm missing?


This was a bug in ExtJS 6.2.0, it was fixed in 6.2.1. Most likely some old .css file hangs somewhere. I am not sure what you exactly mean by "when running app from the root". But you can try to delete .css files in the projectRoot/resoruces

If you see the issue in all the projects you have, try to delete this folder C:\Users\<user>\AppData\Local\Sencha\Sencha Architect 4.0\extracted

mlmcconnell
24 Jan 2017, 6:01 PM
Not sure what that error is. You are doing it right by mapping network drive. As UNC (\\Server\Volume\File ) paths are not supported. But you can keep the file-watcher disabled. It can detect outside changes of the project important files and also re-checks if the files are correctly written to the disk. So you should be able to work without any problems with disabled file watcher.



This was a bug in ExtJS 6.2.0, it was fixed in 6.2.1. Most likely some old .css file hangs somewhere. I am not sure what you exactly mean by "when running app from the root". But you can try to delete .css files in the projectRoot/resoruces

If you see the issue in all the projects you have, try to delete this folder C:\Users\<user>\AppData\Local\Sencha\Sencha Architect 4.0\extracted



Worked perfectly. I really appreciate your quick responses to these issues, Petr. When I said I was running the app from the root, I meant of the project folder. Sorry for the confusion.

You saved me a lot of digging (and frustration) today!

M. McConnell