PDA

View Full Version : Not able to run the application after including gwtext.jar2Posted: Thu Apr 24, 2008 3



Mandy
24 Apr 2008, 8:37 PM
Hi,

I included gwtext.jar 2 and gwtextux.jar in my project.
After this when I run the project there is a java script error "Ext is undefined".
And in log files I see -
[ERROR] Unable to load module entry point class com.nl.client.VWBSampleApp (see associated exception for details)
com.google.gwt.core.client.JavaScriptException: JavaScript TypeError exception: Object expected
at com.google.gwt.dev.shell.ModuleSpace.invokeNative(ModuleSpace.java:481)
at com.google.gwt.dev.shell.ModuleSpace.invokeNativeVoid(ModuleSpace.java:270)
at com.google.gwt.dev.shell.JavaScriptHost.invokeNativeVoid(JavaScriptHost.java:137)
at com.gwtext.client.widgets.Component.init(Component.java:100)
at com.gwtext.client.widgets.Component.<clinit>(Component.java:89)
at com.nl.client.VWBFinance.loadFinance(VWBFinance.java:23)
at com.nl.client.VWBSampleApp.onModuleLoad(VWBSampleApp.java:45)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)

I have added jar files to my project and made changes in module config-
<module>

<!-- Inherit the core Web Toolkit stuff. -->
<inherits name='com.google.gwt.user.User'/>
<inherits name='com.gwtext.GwtExt' />
<inherits name='com.gwtextux.GwtExtUx'/>
<!-- Specify the app entry point class. -->
<entry-point class='com.nl.client.VWBSampleApp'/>
<stylesheet src="js/ext/resources/css/ext-all.css" />
<script src="js/ext/adapter/ext/ext-base.js" />
<script src="js/ext/ext-all.js" />
</module>

I have copied js folder to public folder.

There is a strange, when view my project in JDeveloper js folder is not displayed as a package like client, server folders. Please see attachment.
After rebuilding the project public folder in output directory(www) is empty. It does not have js folder files.

Thanks,
Mandy

Not able to run the application after including gwtext.jar2

lahu
25 Apr 2008, 4:33 AM
gwtext is another library. this here is ext-gwt or the jar is gxt.jar.

see http://gwt-ext.com/

there you will find the documentation for your library

nicrox
25 Apr 2008, 6:58 AM
I agree names are extremly confusing, even deciding which one to use is another hard decision. I think if is alot more suitable if Ext team decided to call it GXT and introduces Ext-Gwt as GXT from now on.

BTW, I also have a problem,
I added gxt.jar to my project and <inherits name='com.extjs.gxt.GXT'/> to myProjec.gwt.xml I got this message,

[ERROR] Unable to find 'com/extjs/gxt/GXT.gwt.xml' on your classpath; could be a typo, or maybe you forgot to include a classpath entry for source?
after playing around abit I realised I had to change <inherits name='com.extjs.gxt.GXT'/>to<inherits name='com.extjs.gxt.ui.GXT'/> since GXT.gwt.xml file is located under com\extjs\gxt\ui

I now get the following error:

[ERROR] Line 5: Unexpected exception while processing element 'inherits'
java.lang.UnsupportedClassVersionError: Bad version number in .class file
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1255)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1189)
at com.google.gwt.dev.cfg.ModuleDefSchema$ObjAttrCvt.convertToArg(ModuleDefSchema.java:493)
at com.google.gwt.dev.util.xml.HandlerArgs.convertToArg(HandlerArgs.java:64)
at com.google.gwt.dev.util.xml.HandlerMethod.invokeBegin(HandlerMethod.java:214)
at com.google.gwt.dev.util.xml.ReflectiveParser$Impl.startElement(ReflectiveParser.java:242)
at org.apache.xerces.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:454)
at org.apache.xerces.impl.XMLNamespaceBinder.startElement(XMLNamespaceBinder.java:571)
at org.apache.xerces.impl.dtd.XMLDTDValidator.startElement(XMLDTDValidator.java:756)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:752)

Also, my gwt version: 1.4.62
JRE = j2re1.4.2_17
Any help is appreciated

darrellmeyer
25 Apr 2008, 8:02 AM
You must use GWT 1.5 m2 or above. And you must use JDK 1.6 with beta1. This will be JDK 1.5 in beta2.

s_kumar
27 Apr 2008, 7:34 PM
You must use GWT 1.5 m2 or above. And you must use JDK 1.6 with beta1. This will be JDK 1.5 in beta2.


Hi darrellmeyer,

I am new to GWT.i picked up a helloworld example from site and try to run it.
I am having my "HelloWorld.html" inside com.mycompany.mypackage.public package under web project.But when i try to run the application through browser using
URL: http://localhost:8080/HelloWorld/com.mycompany.mypackage.public/HelloWorld.html.

it shows HTTP Status 404 : HelloWorld.html is not available.