PDA

View Full Version : error: cannot use 'in' operator to search for 'view' in undefined when create Extjs6



carsonwong
15 May 2017, 6:44 PM
error: cannot use 'in' operator to search for 'view' in undefined when create classic/modern 6.0.x and saved
56289

petr.vecera
16 May 2017, 2:39 AM
Hi

Do you have any other steps ?

Or you just create Modern 6.0 blank project ? Does it also happen in 6.2 projects? Are you on Windows?

Thanks
Petr

carsonwong
16 May 2017, 2:44 AM
Hi,
no other steps.just create blank project, modern / classic 6.0/ 6.2 also happened,
windows 10 64bit

thank you for replied

petr.vecera
16 May 2017, 2:51 AM
Please try to delete this folder C:\Users\<user>\AppData\Local\Sencha\Sencha Architect 4.0\extracted


If you added any extension or saved any components etc, please backup this folder C:\Users\<user>\Documents\Architect and than delete it.

Try to start SA again. It should offer you syncing assets again. Do that, than try to create blank project.


Let me know if that helped you.

carsonwong
16 May 2017, 4:22 PM
I deleted the 2 folders both,and update all assets ,as result the progrem still happened.

but Extjs5.1.x is good.

My Architect is Version 4.1.2 build 188 for trial

petr.vecera
17 May 2017, 12:31 AM
Ok this is really weird, there is like no reason for this to happen. It shouldn't matter if you are on trial / full version.

Btw did it work for you before? Or is this fresh install?

Could you please follow these steps, generate debug log and post it here: https://youtu.be/sXlG3v3n2yA (it's quick 1 minute tutorial / 2 steps )

Thank you

carsonwong
17 May 2017, 12:44 AM
install it in 2 computers ,same problem happened
debug log:


[2676:0517/164011:INFO:CONSOLE(0)] "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.", source: (0)
[2676:0517/164017:INFO:CONSOLE(210)] "Google Maps API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys", source: https://maps.googleapis.com/maps-api-v3/api/js/25/14/util.js (210)
[2676:0517/164025:INFO:CONSOLE(1)] "TODO: implement pref portion of _setEditorOptionAndPref", source: file:///F:/Sencha/Sencha%20Architect%204.1/resources/app.asar/architect-all.js (1)
[2676:0517/164218:INFO:CONSOLE(9424)] "[E] [Ext.Loader] Some requested files failed to load.", source: file:///F:/Sencha/Sencha%20Architect%204.1/resources/app.asar/src/frameworks/ext62/framework/ext-all-rtl-debug.js?_dc=1495010411860 (9424)
[2676:0517/164218:INFO:CONSOLE(9424)] "[E] [Ext.Loader] Some requested files failed to load.", source: file:///F:/Sencha/Sencha%20Architect%204.1/resources/app.asar/src/frameworks/ext62/framework/ext-all-rtl-debug.js?_dc=1495010411860 (9424)

petr.vecera
17 May 2017, 3:36 AM
This is really weird. If it's on 2 separate computers. It has to be something from outside.

Please try to start SA without connection to the network.

Aren't you perhaps located in China? We are tracking some problems from Chinese customers, the golden shield is altering some request from the Ext source code to the google API which results in crash.

If so, please try to block SA from using the network using windows firewall. These request are not needed for SA to work, there are just some default API requests from inside the google package loaded in the ext framework. (The SA canvas(design view) loads all the ext packages by default to support all the possible user configs inside SA canvas)

carsonwong
17 May 2017, 5:33 PM
yes, I come from china, and i block the internet , the problem is solved, thanks a lot

petr.vecera
17 May 2017, 11:46 PM
I am glad that you were able to fix it. It's hard to reproduce this issue for us but we think we fixed it in the next version SA 4.2. So when it comes out , if you could try it and give us feedback it would be awesome. Thank you