PDA

View Full Version : Architect 4.1.2.188 not compatible with theme created by Themer 1.2.0.41?



dleong@celsinc.com
19 Jun 2017, 5:01 PM
I created a theme using Themer 1.2.0.41. I intended to export the theme to a project created by Architect 4.1.2.188. When I tried to import the theme, it gave me an error message about the theme created not compatible with the Architect version.
Is there a solution to resolving this problem?

56484

petr.vecera
20 Jun 2017, 1:32 AM
You need to update to SA 4.2 or use Themer 1.1

Hm but by looking at your message - are you sure that you exported the correct theme ? Maybe your project is classic and you exported modern theme or something?

dleong@celsinc.com
20 Jun 2017, 6:45 AM
Petr, thanks for the posting.
I double checked this morning, the exported theme is classic as is my project in SA.
I will upgrade SA to 4.2 and try again.

dleong@celsinc.com
20 Jun 2017, 8:36 AM
Petr,
Here's what happened:
1. I experienced a problem downloading SA 4.2 so...
2. I downloaded Themer 1.1 and created my custom theme successfully based on CMD 6.2.2 and ext-js 6.0.2
3. I exported the theme to a zip file.
4. I then went back to my project in SA 4.1.2 and tried to import the (now expanded) theme zip file but got an error:

56491

How to resolve this error?

petr.vecera
20 Jun 2017, 9:12 AM
Never seen such error :-/ Are you able to share the theme .zip with us?

Can you also share your exact version: Help -> About , there should be all the info needed.

dleong@celsinc.com
20 Jun 2017, 9:31 AM
Here's the version number of SA.

56493

The zip file is too big to upload here (1.48MB). I uploaded to my Google Drive here: https://drive.google.com/file/d/0B_YfIOTqLk7GTFBWcjNhWXY2QXM/view?usp=sharing

petr.vecera
20 Jun 2017, 9:52 AM
Hm I imported the theme without any problem. Where did you extracted the theme. Try to extract it to some completely new folder which is unrelated from the project and than pick it from there. SA should copy it into the project.

dleong@celsinc.com
20 Jun 2017, 10:49 AM
I exported the theme to an empty folder and expanded the zip file into the same folder as well.
Tried to import into SA but same error message came up. :-(

dleong@celsinc.com
20 Jun 2017, 1:05 PM
OK. I seemed to have resolved the problem, somewhat....
I unzipped the theme package directly into my project "/packages/local" folder and then applied the expanded theme from within SA.
SA seemed happy with it except it did not show all the changes on the design (WYSIWYG) screen.
Something I need to run tests on...

dleong@celsinc.com
21 Jun 2017, 7:46 AM
Just as I reported back earlier, the theme was adopted into my project in SA but it did not reflect on the visual design screen.

56498 56499

Is there any step that I missed?

petr.vecera
22 Jun 2017, 1:16 AM
Try to click on the Recompile Theme button in the right bottom corner. Next to the compile CSS progress bar.

http://imgur.com/a/kq5Uz

if that doesn't help, try to find and delete any files named .architect-internal-preview in your project. They should be in the root folder or in the resources folder.