PDA

View Full Version : [OPEN] [bug report] Ext.dataview.listswiper.ListSwiper.widget references stepper incorrectly



valio
22 Jun 2017, 12:59 AM
In the docs for Ext.dataview.listswiper.ListSwiper.widget (http://docs.sencha.com/extjs/6.5.0/modern/Ext.dataview.listswiper.ListSwiper.html#cfg-widget) there is a reference to "Ext.dataview.plugin.ListSwiperStepper (http://docs.sencha.com/extjs/6.5.0/modern/Ext.dataview.plugin.ListSwiperStepper.html)".
However this is the wrong name for the intended class.

The correct class name would be Ext.dataview.listswiper.Stepper (http://docs.sencha.com/extjs/6.5.0/modern/Ext.dataview.listswiper.Stepper.html).

As an additional doc improvement note I would suggest to reference Ext.dataview.listswiper.Accordion (http://docs.sencha.com/extjs/6.5.0/modern/Ext.dataview.listswiper.Accordion.html) there as well, even though it's supposed to be an internal utility class (but then it's the default value for the Ext.dataview.listswiper.ListSwiper.widget (http://docs.sencha.com/extjs/6.5.0/modern/Ext.dataview.listswiper.ListSwiper.html#cfg-widget) config).

greg.barry
26 Jun 2017, 10:19 AM
Thanks for the report! I have opened a bug in our bug tracker.