PDA

View Full Version : Embedded fiddle shows warnings and errors



LesJ
11 Jul 2017, 6:56 AM
Am I doing something wrong?

231h

mitchellsimoens
11 Jul 2017, 7:01 AM
I'm not getting any errors or warnings when ran or when clicking on the button.

mitchellsimoens
11 Jul 2017, 7:03 AM
Oh I see, when embedded, skipped over that in the title. It works from the fiddle app but looks like it's not able to find posts.json on the request.

LesJ
11 Jul 2017, 7:19 AM
Oh I see, when embedded, skipped over that in the title. It works from the fiddle app but looks like it's not able to find posts.json on the request.

So, is this a fiddle issue? Can I prevent these errors?

mitchellsimoens
11 Jul 2017, 7:20 AM
A fix is being deployed atm.

mitchellsimoens
11 Jul 2017, 8:05 AM
Try it now.

Took a bit longer, I checked the fix into git but forgot to publish the npm module so had to deploy a 2nd time.

LesJ
12 Jul 2017, 8:13 AM
I still see warnings and errors. I tested on Chrome and Windows 7. Screenshot attached.

231h

56610

LesJ
12 Jul 2017, 8:24 AM
The error and warning icons are visible only when I embed the fiddle.

When I click the "Open in Fiddle" link, they disappear.

mitchellsimoens
12 Jul 2017, 9:07 AM
There are two things here and which was one was not specified.

1) My fix was to fix loading of the posts.json when embedded.
2) The warnings in the embedded ace editor is a different matter.

I fixed #1 because it was a blocker bug. #2 isn't a blocker but would be nice to use the jsx mode instead of javascript like it does in the main fiddle app but I'm working on Ext JS atm and not fiddle so #2 won't be fixed right away.