View Full Version : [FIXED] Internal compiler errors w/ Beta 4

2 Jun 2008, 3:58 PM
I'm trying to use GXT 1.0 Beta 4, but everytime I try to use a ContentPanel, I get internal compiler errors. The code in question looks like:

ContentPanel panel = new ContentPanel();
panel.setTitle("Title Goes Here");

and the errors generated are:

Error:An internal compiler exception occurred
Error:at com.google.gwt.dev.jjs.ast.JVisitor.translateException(JVisitor.java:538)
Error:at com.google.gwt.dev.jjs.ast.JVisitor.doTraverse(JVisitor.java:529)
Error:at com.google.gwt.dev.jjs.ast.JModVisitor$NodeContext.traverse(JModVisitor.java:154)
Error:at com.google.gwt.dev.jjs.ast.JModVisitor.doAccept(JModVisitor.java:192)
Error:at com.google.gwt.dev.jjs.ast.JVisitor.accept(JVisitor.java:65)
Error:at com.google.gwt.dev.jjs.ast.JIfStatement.traverse(JIfStatement.java:51)
Error:at com.google.gwt.dev.jjs.ast.JVisitor.doTraverse(JVisitor.java:527)
Error:at com.google.gwt.dev.jjs.ast.JModVisitor$ListContext.traverse(JModVisitor.java:100)
Error:at com.google.gwt.dev.jjs.ast.JModVisitor.doAcceptWithInsertRemove(JModVisitor.java:212)
Error:at com.google.gwt.dev.jjs.ast.JVisitor.acceptWithInsertRemove(JVisitor.java:81)
Error:at com.google.gwt.dev.jjs.ast.JBlock.traverse(JBlock.java:36)
Error:at com.google.gwt.dev.jjs.ast.JVisitor.accept(JVisitor.java:73)
Error:at com.google.gwt.dev.jjs.ast.JMethodBody.traverse(JMethodBody.java:52)
Error:at com.google.gwt.dev.jjs.ast.JVisitor.accept(JVisitor.java:69)
Error:at com.google.gwt.dev.jjs.ast.JMethod.traverse(JMethod.java:189)
Error:at com.google.gwt.dev.jjs.ast.JClassType.traverse(JClassType.java:62)
Error:at com.google.gwt.dev.jjs.ast.JModVisitor.doAccept(JModVisitor.java:202)
Error:at com.google.gwt.dev.jjs.ast.JVisitor.accept(JVisitor.java:77)
Error:at com.google.gwt.dev.jjs.ast.JProgram.traverse(JProgram.java:799)
Error:at com.google.gwt.dev.jjs.impl.EqualityNormalizer.execImpl(EqualityNormalizer.java:198)
Error:at com.google.gwt.dev.jjs.impl.EqualityNormalizer.exec(EqualityNormalizer.java:187)
Error:at com.google.gwt.dev.jjs.JavaToJavaScriptCompiler.compile(JavaToJavaScriptCompiler.java:424)
Error:at com.google.gwt.dev.GWTCompiler.realizePermutation(GWTCompiler.java:511)
Error:at com.google.gwt.dev.GWTCompiler.compilePermutations(GWTCompiler.java:442)
Error:at com.google.gwt.dev.GWTCompiler.distill(GWTCompiler.java:358)
Error:at com.google.gwt.dev.GWTCompiler.run(GWTCompiler.java:564)
Error:at com.google.gwt.dev.GWTCompiler.run(GWTCompiler.java:554)
Error:at com.google.gwt.dev.GWTCompiler.main(GWTCompiler.java:214)
Error:at com.google.gwt.dev.jjs.impl.EqualityNormalizer$BreakupAssignOpsVisitor.endVisit(EqualityNormalizer.java:86)
Error:at com.google.gwt.dev.jjs.ast.JBinaryOperation.traverse(JBinaryOperation.java:79)
Error:at ButtonBar.java(83): null.nullField == 640
Error:at ButtonBar.java(83): if (null.nullField == 640) {
Error:at ButtonBar.java(82): {
Error:at ButtonBar.java(82): public final void handleEvent(<null> be);
Error:at ButtonBar.java(81): final class ButtonBar$1 extends Object implements Listener
Error:<no source info>: <JProgram>

2 Jun 2008, 6:05 PM
are you using GWT 1.5 RC1 ??

2 Jun 2008, 6:06 PM
Yes, sorry. I'm using GWT 1.5 RC1 and GXT Beta 4.

2 Jun 2008, 6:18 PM
...compile is working fine for me on all things using GXT beta 4 and GWT 1.5 rc1


1) can you include a full working source file for me to try (to confirm its not your code).

2) how are you compiling? I'm clicking on compile/browse in hosted mode - this is the easiest way to ensure your setup is working (because if the hosted mode works, then compile will too)

3 Jun 2008, 4:25 AM
I switched to my laptop using XP and ran into the same issue when compiling my code. The compiler does not seem to like ButtonBar. I am not sure why GWT is complaining, but I reworked the code and was able to get rid of the error. The change is in SVN.

3 Jun 2008, 6:37 AM
I've got the same error. I'm trying to download the code with TortoiseSVN from the subversion repository (http://code.extjs.com/svn/gxt/trunk), but it asks me for username and password (which I obviously don't have). I've also tried with Subclipse, but the connection is refused. Any hints?

3 Jun 2008, 6:54 AM
Read-only SVN access is provided with Support Subscriptions (http://extjs.com/store/gxt/#support-table).

3 Jun 2008, 7:27 AM
We are migrating from Gwt-Ext to GXT, we have a deadline near, and we are evaluating GXT right now. We are going to pay the license (maybe an expensive one) because we are working in a commercial project, but we won't adquire the product until we find that it completely fit our needs.

Now my project is frozen because of this critical bug (and so my work) until a new beta is released. The code is provided in the GXTbeta4 zip, but there are no scripts to build it, neither I have the required knowledge to find and patch the code.

Then, are you going to release a public fix soon? By the way, I don't understand why the read-only access to the svn repository is restricted. It doesn't make sense, I'm not going to purchase a license right now to gain access to it. My company won't buy me a license to overcome this problem. Although I really appreciate your hard work, Darrell, and I think it's really good, it's an annoyance that an open source project is restricting the access to the code. Is it GPL because the Ext team is in accordance to the GNU philosophy? Then open the subversion repository to the public. The companies, like us, will buy the license anyway.

3 Jun 2008, 8:15 AM
I have updated the beta 4 download (http://extjs.com/products/gxt/download.php?dl=gxt10beta4) with a new build that includes the fix.

3 Jun 2008, 7:37 PM
Hello Darrell!

Thanks for your efforts in responding the users, but it seems that this new download you posted has a problem! It's blocking the textfields from accepting inputs... in HostedMode and most browsers (it seems to be working only in Safari). I tested it, and the beta4 download that has this compilation problem doesn't have the textfield problem...

This simple code will generate the textfield problem with the new download:

public void onModuleLoad() {
RootPanel.get().add(new TextField<String>());

I have updated the beta 4 download (http://extjs.com/products/gxt/download.php?dl=gxt10beta4) with a new build that includes the fix.

4 Jun 2008, 2:42 AM
Well that is not good. I have updated the build (again). Let me know if you still have any problems.

4 Jun 2008, 5:26 AM

I have the same problem.

I just built revision 366, and the problems remains, my text fields are not responding... Is the fix in SVN or only in the downloadable revision?

4 Jun 2008, 5:32 AM
I fixed SVN. Try now.