PDA

View Full Version : GeoExt on Architect: is it possible?



Mellgood
10 Oct 2017, 6:35 AM
Hello there,
I'd like to use GeoExt on Architect but i'm haveing a lot of problems.
Has anyone tried it yet or maybe someone wants to help me to configure Architect properly?
The problem is that GeoExt semms to not provide an Architect package (.aux file) so I think that i have to import manually the library.
I tried to follow instructions provided for Sencha CMD here (https://github.com/geoext/geoext3#how-to-use-geoext-3-inside-your-sencha-app) and here (https://github.com/geoext/geoext3#alternatively-as-a-sencha-cmd-package)with no luck at all..

Am I missing something? I'm stucked in a situation that I can not handle and i have no clue on what I can try to do.

petr.vecera
30 Oct 2017, 7:56 AM
As Cmd package should be most easy https://github.com/geoext/geoext3#alternatively-as-a-sencha-cmd-package

You should be able to edit app.json in your app and that should be it.

What exactly doesn't work? Do you have some error message etc?

Mellgood
30 Oct 2017, 8:25 AM
Yes, I tried the way you mentioned but i'm not able to instantiate any GeoExt class. For instance if i launch


mapComponent = Ext.create('GeoExt.component.Map', {});

I get the following error:
57148

I solved the problem in a tricky way that i can not consider a canonical approach to Architect, but it worked for me.
1. Add a new js resource to the project inspector and set the ol url https://openlayers.org/en/v4.4.2/build/ol.js
2. Create folder MyProject\packages\remote
3. Add GeoExt to the remote folder
4. Check MyProject\packages\remote\GeoExt\src is the src folder of GeoExt
5. Replace "classpath" attribute with the following lines, in app.json:


"classpath": [


"app",
"packages/remote/GeoExt/src"

],

Even if it works, I'm not sure at all that it is the right way to use it..