PDA

View Full Version : Problem with running command from menu



karoop
20 Feb 2018, 1:21 AM
It looks like I can't use the word "w.a.t.c.h" (obviously without the dots) in a post. Replace every occurrence of 'sencha app look' in my post with the actual command that I cannot write here for some reason.

Now to the main problem: Often when I select 'Run sencha app look' on an app in my workspace for the first time after opening VSCode, only Ext JS reindex is triggered and app look never runs. Selecting the menu option again works OK.


Steps to reproduce the problem:


Close VSCode completely.
Open VSCode in a workspace.
Right-click on an app and select 'Run sencha app look'.
Status bar reports that Ext JS is being reindexed and app look doesn't run.
Repeat step 3.
Sencha app look actually runs.



I'm on VSCode version 1.20.1 and Sencha Ext JS extension version 1.0.1.

Jaraj
5 Mar 2018, 7:11 AM
Hi,

Since you are running the commands immediately, once VScode launches, it looks as if the command triggers the re-indexing and the app runs when the command is run the second time.

I tested this from my end and this is not the case.

Whenever vscode is launched, it will initiate a indexing of EXTJS and you will able to run apps only after the indexing is complete. If you launch the application and wait for a few seconds, the indexing should be triggered automatically. This is not dependent on running sencha app watch / sencha app look on your app in the workspace.

Hope this helps.

Regards,
Joe

Sencha Support Team

karoop
5 Mar 2018, 7:21 AM
I tested this from my end and this is not the case.

Whenever vscode is launched, it will initiate a indexing of EXTJS and you will able to run apps only after the indexing is complete. If you launch the application and wait for a few seconds, the indexing should be triggered automatically. This is not dependent on running sencha app w.a.t.c.h / sencha app look on your app in the workspace.


Thanks. If that's the case, shouldn't the users get a message telling them what's going on? Right now I often end up starting Sencha app w.a.t.c.h (here it is again, I couldn't write the word) and then sitting there wondering what's going on without any clue while nothing happens.

Jaraj
5 Mar 2018, 1:06 PM
I think VScode considers indexing extjs files as part of its launch phase - Hence the notification at the bottom of the screen showing the progress. However, I did not see it taking more that an 3-5 seconds and the indexing was over by then - There is a possibility of VScode taking longer than usual for indexing.

I would suggest waiting till the indexing completes and then running the commands. The other option would be to open a ticket in the support portal so that a Engineer can look into this issue further.

Regards,
Joe

Sencha Support Team

karoop
6 Mar 2018, 12:42 AM
Yes, I know that either waiting or selecting the sencha app w.a.t.c.h from the menu twice resolves the issue.

I started the thread here because I wanted to help improve the plugin by reporting a bug. Do you not think that what I reported is a bug? Is this not the right place to report a bug? The message on the top of each thread here says:



Thank you for reporting this bug. We will make it our priority to review this report.


Thanks anyway for looking into it.