PDA

View Full Version : GWT 2.8.0 deployment error



rameshv941
19 Oct 2018, 11:09 AM
I am trying to deploy my GWT app with GXT 4.0.2 to a Weblogic 12.2.1 server. I get the following error.
I don't get the error with GWT 2.7.0 everything else being identical(except the module xml file).
Anyone else see this error? I read that GWT 2.8.0 implements websockets. Is this issue related to that?
I would appreciate any help. Thanks.

Ramesh


Caused by: javax.servlet.ServletException: Not running on Jetty, JSR-356 support unavailable
at org.eclipse.jetty.websocket.jsr356.server.deploy.WebSocketServerContainerInitializer.onStartup(WebSocketServerContainerInitializer.java:146)
at weblogic.servlet.internal.WebAppServletContext.initContainerInitializer(WebAppServletContext.java:1420)
at weblogic.servlet.internal.WebAppServletContext.initContainerInitializers(WebAppServletContext.java:1359)
at weblogic.servlet.internal.WebAppServletContext.initContainerInitializers(WebAppServletContext.java:1340)
at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1906)
at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3063)
at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1830)
at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:875)
at weblogic.application.internal.ExtensibleModuleWrapper$StartStateChange.next(ExtensibleModuleWrapper.java:360)
at weblogic.application.internal.ExtensibleModuleWrapper$StartStateChange.next(ExtensibleModuleWrapper.java:356)
at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:45)
at weblogic.application.internal.ExtensibleModuleWrapper.start(ExtensibleModuleWrapper.java:138)

Forum_Adm
7 Nov 2018, 8:42 AM
Hi Ramesh,

Sorry for the delay in responding. I have shared this with the support team and asked that they follow up with you to provide some assistance. Thank you for your patience!

Michele