PDA

View Full Version : ExtAngular npm start (Failed to compile)



pumm
23 Jan 2019, 9:25 PM
$ npm start


> @sencha/ext-angular-boilerplate@6.7.0 start E:\work\extAngular\cool-ext-angular-app-3
> npm run dev




> @sencha/ext-angular-boilerplate@6.7.0 dev E:\work\extAngular\cool-ext-angular-app-3
> webpack-dev-server --env.verbose=no --env.environment=development --env.browser=true --env.watch=yes


undefined
i [ext]: ext-webpack-plugin v6.7.0, Ext JS v6.7.0 Commercial Edition, Sencha Cmd v6.7.0.36, webpack v4.29.0, angular v7.2.2
i [ext]: Building for development
i 「wds」: Project is running at http://0.0.0.0:1962/
i 「wds」: webpack output is served from /
i 「wds」: Content not from webpack is served from ./build
i 「wds」: 404s will fallback to /index.html
i [ext]: Adding ext-angular\ext.js and ext-angular\ext.css to index.html
i [ext]: Building Ext bundle at: \build\ext-angular
i [ext]: [ERR] Directory \build\ext-angular\node_modules\@sencha\ext not recognized as a framework
i [ext]: [ERR] Unable to load required framework: ext@null
i [ext]: Opening browser at http://localhost:1962
i [ext]: Completed ext-webpack-plugin processing
× 「wdm」: Built at: 2019-01-24 09:24:51
Entrypoint polyfills = polyfills.js polyfills.js.map
Entrypoint main = main.js main.js.map


ERROR in i [ext]: Directory \build\ext-angular\node_modules\@sencha\ext not recognized as a framework


ERROR in i [ext]: Unable to load required framework: ext@null


ERROR in 321
i 「wdm」: Failed to compile.


There is no node_modules \ @sencha \ ext in that directory (\ build \ ext-angular).

I want to do this.

help me

Forum_Adm
1 Feb 2019, 1:55 PM
Hello there- sorry for the delay in response. I have shared this with the support team. Someone will be reaching out to you soon to provide some assistance. Your patience is greatly appreciated.

Thanks,

Michele

sandeep.adwankar
5 Feb 2019, 3:17 PM
We pushed updates to ExtAngular packages. Can you pl. retry? Thx!


$ npm start


> @sencha/ext-angular-boilerplate@6.7.0 start E:\work\extAngular\cool-ext-angular-app-3
> npm run dev




> @sencha/ext-angular-boilerplate@6.7.0 dev E:\work\extAngular\cool-ext-angular-app-3
> webpack-dev-server --env.verbose=no --env.environment=development --env.browser=true --env.watch=yes


undefined
i [ext]: ext-webpack-plugin v6.7.0, Ext JS v6.7.0 Commercial Edition, Sencha Cmd v6.7.0.36, webpack v4.29.0, angular v7.2.2
i [ext]: Building for development
i 「wds」: Project is running at http://0.0.0.0:1962/
i 「wds」: webpack output is served from /
i 「wds」: Content not from webpack is served from ./build
i 「wds」: 404s will fallback to /index.html
i [ext]: Adding ext-angular\ext.js and ext-angular\ext.css to index.html
i [ext]: Building Ext bundle at: \build\ext-angular
i [ext]: [ERR] Directory \build\ext-angular\node_modules\@sencha\ext not recognized as a framework
i [ext]: [ERR] Unable to load required framework: ext@null
i [ext]: Opening browser at http://localhost:1962
i [ext]: Completed ext-webpack-plugin processing
× 「wdm」: Built at: 2019-01-24 09:24:51
Entrypoint polyfills = polyfills.js polyfills.js.map
Entrypoint main = main.js main.js.map


ERROR in i [ext]: Directory \build\ext-angular\node_modules\@sencha\ext not recognized as a framework


ERROR in i [ext]: Unable to load required framework: ext@null


ERROR in 321
i 「wdm」: Failed to compile.


There is no node_modules \ @sencha \ ext in that directory (\ build \ ext-angular).

I want to do this.

help me

pumm
7 Feb 2019, 4:24 PM
Thanks, Michele

it's work~~ ^^