PDA

View Full Version : Sencha Themer for Ext JS 6.7



aappell
7 Feb 2019, 11:14 AM
When can we expect a new version of Themer that supports Ext JS 6.7?

Forum_Adm
20 Feb 2019, 11:24 AM
Hi there- I am sorry I do not have an ETA. I have passed this along to an associate to look into and we will get back with you. Thanks for your patience!

Michele

Sergey89rus
27 Feb 2019, 2:51 AM
Any updates on Sencha Themer for ExtJS 6.7?

rakumar
4 Mar 2019, 11:29 AM
Hello,

Thank you for contacting Sencha. As per the recent update we received from the Product Management group, this will be available within 2 weeks however the information on the exact date is not available as of now. We will keep you posted on this thread regarding the same as soon as that is updated to us.

Regards,
Kumar
Sencha Support.

aappell
14 Mar 2019, 10:32 AM
I upgraded Sencha Cmd to 6.7.0.63 and Themer to 1.3.5. Now I'd like to upgrade the ExtJS framework version of my theme from 6.6.0.286 to 6.7.0.210. What is the correct method of doing this? I don't see an option in Themer to do it.

2 hours later...
OK, I ran: sencha app upgrade --full "<path to ExtJS>\ext-6.7.0.210".

This seemed to have worked even though an error occurred:
[ERR] <path to Sencha Cmd>\6.7.0.63\plugins\ext\current\plugin.xml:557: com.sencha.exceptions.ExScript: The choice of Java constructor java.io.File matching JavaScript argument types (null,string) is ambiguous; candidate constructors are:
File(java.lang.String,java.lang.String)
File(java.io.File,java.lang.String) (anonymous#12)
runAppUpgrade (anonymous:11)
[anonymous] (anonymous:464)
x_app_upgrade (anonymous:463)

I'm not going to try to debug this as long as the upgraded theme works.