PDA

View Full Version : Ext.application is not a function in browser's console



itsupport_at_ventana
18 Mar 2019, 2:55 AM
On a Linux machine:
$ ext-gen
Sencha ExtGen v6.7.0 Professional Edition - The Ext JS code generator
$ node -v
v11.11.0
$ npm -v
6.9.0
$ java -version
java version "1.8.0_172"


$ ext-gen app -a MyApp

$ cd my-app



$ npm start

The application starts in the browser but the console shows this error:

Uncaught TypeError: Ext.application is not a function
at Object../app.js (main.js:96)
at __webpack_require__ (main.js:20)
at Object.0 (main.js:9577)
at __webpack_require__ (main.js:20)
at main.js:84
at main.js:87

wemerson.januario
21 Mar 2019, 9:27 AM
I have this odd error too

Windows PC

stildalf
24 Mar 2019, 11:39 AM
Similar experience here, slightly different environment to OP, but also on Linux OS.

Issue was first noticed after upgrade to v6.7.0 CE, not seeing the same for v.6.6.0 CE ext-gen'd apps.

I get 3x the TypeError, then the app seems to carry on regardless, almost like something is trying to jump the gun on the boostrapping process, but then eventually runs.


Uncaught TypeError: Ext.application is not a function
at Object../app.js (app.js:1)
at __webpack_require__ (bootstrap:19)
at Object.0 (log.js:47)
at __webpack_require__ (bootstrap:19)
at bootstrap:83
at bootstrap:83




$ext-gen
Sencha ExtGen v6.7.0 Community Edition - The Ext JS code generator
$node -v
v8.15.1
$npm -v
6.9.0
$java -version
java version "1.8.0_181"

cartomatic
13 Apr 2019, 9:46 AM
win 10
java "1.8.0_202
nodejs 11.14.0



main.js:96 Uncaught TypeError: Ext.application is not a function
at Object../app.js (main.js:96)
at __webpack_require__ (main.js:20)
at Object.0 (main.js:9605)
at __webpack_require__ (main.js:20)
at main.js:84
at main.js:87


a month since the original posting and not a single word from sencha? c'mon chaps, you can do better than that...

wemerson.januario
14 Apr 2019, 10:57 AM
I guess next ext-gen release will fix it.

https://github.com/sencha/ext-gen/pull/181

mgusmano
16 Apr 2019, 2:50 AM
correct, the fix will be in 6.7.1 - we are currently in testing of that version

wemerson.januario
16 Apr 2019, 3:05 AM
Thank you Marc for updates.